Forum search does not recognize Japanese

This issue was apparently addressed in the past:


But in that thread, WK staff said they fixed it, and that was over a year ago!

However, I’ve been having issues now with searches in kana/kanji returning no results
image
It’s made all the more painful, because the page hijacks the browser ctrl+f search (which actually works), and overrides it with the busted Discourse search.

This must be a regression in the past year.

Anyone else experience this?

2 Likes

I was able to search without those issues. The screenshot below is the results of using your example kana in the search. I clicked on one of the results and used find in page which implemented the native browser find and not a Discourse find.

I’m running Chrome (latest) on Windows 10. I’m not sure why our experience differs, but it’s safe to say you’re not stupid :slight_smile:

In your example, you have the box “search this topic” checked. Could that possibly be the problem?

I did a test.

Searched for the Japanese title of a topic elsewhere on the forum while looking at your post with the checkbox checked.

Then without the checkbox.

Yeah, it seems like search is maybe only broken when you do “search this topic”.

But in my case, I was indeed trying to search for a word that I knew was in the topic I was looking at.
image

If you see this screenshot, 「あたし」 is right here in the topic, but wasn’t picked up in the search results.

I see what you mean. I tried searching [あたし] in this topic. It first said no results found, and then gave a red warning box that search query was too short. This was on my Android phone.

Apparently Discourse behaves differently for posts with more than 20 replies. Whether or not a post is listed, may also be a factor.

You should be able to override the search in page by pressing CTRL+F again. But on a >20 reply post the actual results will still be influenced by which portions of the topic have been loaded (into the DOM).

I find, in-thread, that it is incapable of picking up hiragana. It can pick up kanji fine, but as soon as you add any hiragana it becomes clueless.

So ありがとう won’t work, 友達 will, but 来る won’t. The in-browser find function still highlights any instances it finds, so if you scroll down the page they’ll be picked out, but obviously that’s not particularly helpful.

To be fair the search on Discourse is terrible in general.

4 Likes

Right, the browser ctrl+f still works, but is useless in large threads where the post I’m searching for yet hasn’t been loaded.

I’ll send an email to WK because this seems to be a real bug at this point.

My browser ctrl-f just opens up Discord’s search box. I’ve been trying to work out how to make it not do that…

I just place my cursor in the URL first

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.