Extensions not working

Hi there I’ve been using the kiwi mobile browser to run my wani kani extensions but it stopped working for some reason. I’ve updated everything and it still won’t work. What mobile browser do you all use to run extensions for wanikani?

1 Like

I think most people just do phone reviews on an app, so I’m not sure if many people will be able to help. The apps have a lot of popular userscripts built into them though, so maybe give one of them a go.

1 Like

Are you talking about browser extensions or userscripts? What exactly stopped working? All scripts? Just a few? Or the whole browser? I just tested a userscript in the newest version of Kiwi on Android, and everything works fine for me. Are you using Tampermonkey?

Assuming you are using userscripts in Tampermonkey, you could check if Tampermonkey is active. Go to a webpage where you would expect one or more of your userscripts to run. Open the menu and scroll to the bottom, where the Tampermonkey icon should be. Click it and check if Tampermonkey is active and if the scripts you expect to be running on this webpage are active (sorry that the screenshots are in German).

I just now (finally) got Tapermonkey and the script to install, but for some reason the download for Tapermonkey kept bugging. I had to download the Tapermonkey beta in order to get it to install and run scripts propperly. No idea if this will help you, but it’s what finally worked for me

I wasn’t aware there were apps for wanikani with script support :thinking:

I reinstalled kiwi and tampermonkey. Tried installing a script and it doesn’t get past the page with the install button. Looks like I’m doing something wrong now. It worked fine when I did this a few months ago. Then all scripts stopped working and I made sure tampermonkey was active. I restarted my phone and they worked again. This time though restarting my phone didn’t bring them back. I’ll try the beta next or just look for the app

so after reinstalling kiwi and tampermonkey a bunch and it just hanging up on the loading icon whenever i tried accessing it, i just installed violent monkey and the scripts and it works fine.