Can't connect to KaniWani

Hey guys,
I am experiencing a problem with KaniWani. For the last two days I could neither do lessons nor reviews. The content just did not load.
So I tried logging out and in again.
But I cannot log in anymore. :sob: I know my username and password and haven’t made any changes whatsoever. I have been using KaniWani for a year every day and I never had this issue.
Whenever I try to log in, it says:
‘There was an error contacting the server.’
Has anyone experienced the same problem? Or does anybody have an idea what might be the problem?
I don’t know what to do anymore… Thanks in advance for your help! :smiley_cat:

2 Likes

I apologize in advance for how confusing the following may be, but…there are just so many different things that could cause that. :face_with_spiral_eyes:

First and foremost, the “simplest” thing it could be that would also negate any other suggestions is incorrect date/time/zone settings on the device. A secure connection can fail (producing that error) if the time is off by even a little. Long story short, I’d suggest double-checking that, and setting it manually if needed. (Also, make sure that your OS and browser are up to date, as having one pending can cause issues as well.)

Next, if the above isn’t the issue, then a good place to start is trying a different web browser. If it works, then you know that it’s something specific to the browser you’ve been using: settings, a bad update, 3rd party extensions, etc. That also gives you a workaround.

But if using another browser makes no difference, then it’s something with your device, local network (restarting device and router is a good bet), or possibly even settings or routing that happens from your ISP to WaniKani.

Again, sorry that this isn’t exactly an obvious solution, and is potentially quite the rabbit hole. But if you’re still having trouble, just let me know any result or other clues you find and I’ll be happy to see if there’s something else I can suggest based on them. :slight_smile:

1 Like

You should try emailing them at hello@wanikani.com, they usually reply faster that way especially for technical issues.

And of course make sure that you use the correct URL: https://www.wanikani.com/

1 Like

OP is having issues with KaniWani, not Wanikani. KaniWani isn’t run by Wanikani so they can’t help.

4 Likes

I don’t really use KaniWani but I just logged in and everything’s working fine for me.

3 Likes

Ooh, I misread. Sorry for the confusion.

2 Likes

Hi Brenty,
thanks so much for your help and your detailed explanation! I really appreciate it. :heart:
I tried logging in on another device. And it worked! So at least I can access KaniWani.
I have been using KaniWani on my phone. And there it is still not working. My guess is that my browser is outdated. It’s a fairly old smartphone and many updates are not available for me anymore…
I also checked the “time issue” and set it manually. But that did not help.
Again, thanks for your help!

2 Likes

Thank you, simias and darkness_rising, for your input as well! But yes, I am having issues with KaniWani and not WaniKani.

2 Likes

Ah, I misread that too, though my advice would be the same either way. Good to have a sanity check if others are having issues. Glad that you at least have a workaround!

I suspect you’re right about the outdated OS and/or browser being the issue. While it’s definitely best to update (and upgrade if updating isn’t an option), using a 3rd party app/browser (if available) to access KaniWani may help.

Out of curiosity, what is the device/OS you have there?

1 Like

Haha, ok, to satisfy your curiosity. Though I probably shouldn’t say it out loud… Huawei Honor PLK-L01 with Android 6 :scream:

2 Likes

Oh wow. I remember those. :laughing: I was thinking I’d look up cutoffs for browsers on the OS version, but…yeah, I am sure that’s way past any. Honestly, I’m surprised that HTTPS/SSL/TLS connections work at all on Marshmallow, nearly a decade after it was released. :dizzy_face:

Yeah, I am actually surprised too. :sweat_smile: But the last couple of months problems with apps and so on are beginning to increase. So I need to say bye to my phone soon.

1 Like

Aha! I knew I’d heard something about Marshmallow recently. This will be why things have suddenly gotten worse:

(From the Ars Technica review of Android 14)

Developers know that it’s really the end of the road for Marshmallow, so it’s not worth maintaining compatibility any longer (a lot of cost and hassle).

Definitely time to upgrade! :pray:

2 Likes

Isn’t that saying that Marshmallow is the oldest version that still handles the minimum API, i.e it’s still ok but not anything older?

(Of course the change may have prompted app developers to look again at what minimum version they’re targeting and choose themselves to set it to something newer than the Google enforced minimum.)

2 Likes

Yeah, that’s exactly it, on both counts!

That’s why not all apps no longer work on Android 6: it’s possible, just not worth it for anyone still maintaining them, as the writing is on the wall. I suspect that most (if not all) that do still work only do because they’re abandoned and no longer being updated at all (e.g. to use newer APIs). If you’ve already got them installed, they won’t go away, after all.

1 Like

That explains things… Yeah, upgrade it is then.:grimacing:

2 Likes