WaniKanify 2.0 - Chrome Extension

That’s weird, the ID on our extension is different:

image

I thought these were unique to the extension?

Can you both please try this:
@sakaijin
Google: “mgnblnbdmneollbncamkogcpgpjgekpf” and see if it brings up this link:

image

If it does, install it (again) and see if it works? this is probably completely illogical or maybe the ID is unique to each user. But it can’t hurt to try :smiley:

I like your commitment to solve it :clap:

I had the same version, same ID, v2.0.1. Reinstalled, nothing changed.

1 Like

I would say “Is it your version of chrome?” but i’m pretty sure Chrome keeps itself up to date haha. Unless you’re using Chrome Canary or something like that :smiley: .

Sounds cool but no firefox support?

@sakaijin @Lewby @4183R7 @jmaher16

Take a look at the 2nd post in this thread. I updated with some API token info in case it was pasted incorrectly by a user.

The promise issue is odd, will take a look and see about adding some handling in this weekend. Also what webpages are you running on? Lastly, please set the application to “On Click” instead of “Automatically” as the extension will run on all pages and clutter your logs during testing.

Extension ID: mgnblnbdmneollbncamkogcpgpjgekpf

My personal Chrome settings as of April 8th, 2021 is the following.
Chrome Version: 89.0.4389.114 (Official Build) (64-bit)

2 Likes

I have all the boxes ticked for my API because I’m a big dumb dumb, but it doesn’t matter / doesn’t affect anything. Just means that the extension could technically change stuff on my WK which is fine, I’ll go through my API tokens later and sort them all out haha since I’m sure i’ve done the same with a ton of the other ones too :slight_smile:

I lowkey wonder if it’s something to do with the webpage loading, maybe the extension is somehow trying to run before the content is there for some reason, I’m sure you’ll work it out tbh @ThePieMonster you da MvP, I’ll stop trying to solve it now @sakaijin I haven’t done any programming in a few years and while I do enjoy problem solving I think I’m all out of ideas :slight_smile: I’m sure Pie will figure it out!

1 Like

@ThePieMonster and @Lewby

Thanks for your help guys, really. I know you want to solve it and get to the bottom of it but I’m just putting it to the side, for now. It’s probably some kind of stupid thing on my end. I even reinstalled the latest version of the Chrome browser cleanly and set it up with the Wanikanify v2.0.1 extension only. Nope. I look at it later, maybe I missed something…

Like I said before, I’m super glad it works for others. It’s a great extension to use. Plus, I’m really happy that you brought it back to life :+1: Peace guys :facepunch:

1 Like

It doesn’t convert simple Kanji, right? Only vocabulary?

@Vikestart Its for vocab but kanji on their own are also vocab.

Sounds cool but no Firefox support?

@f3lix Perhaps in the future.

I’m sure Pie will figure it out!

@Lewby Haha I hope! Appreciate it Lewby. It’s always nice to have someone else helping out especially since I’m only on later in the evening. You mentioned you did some programming in the past, feel free to take a look at the project on GitHub if your interested. Would be great to add contributors to the project!

I even reinstalled the latest version of the Chrome browser cleanly and set it up with the Wanikanify v2.0.1 extension only. Nope. I look at it later, maybe I missed something…

@sakaijin Thanks for sticking it out this far. You did try the extension on the Pastebin page and you have these issues still, right? Just want to see the outcome on a controlled webpage like the PastBin link I have in the first post. Again, will have to look into some better logging / error handling to see what the true issue this weekend.

2 Likes

Yep, that’s the one I always checked if it worked.

I cloned the git repo and loaded an unpacked extension, so that’s why the ID may be different. Tried the version from the store, also doesn’t work.

2 Likes

I found the issue, it was something to do with pagination if you have more than 1000 items. I fixed it, check the pull request on GitHub!

5 Likes

Thanks @Flameaxe. I merged that change in and updated the Chrome Extension.

Everyone, it will take a few days for the updated extension to show up in the store. You will want to keep a eye out for version 2.0.2.

6 Likes

It still doesn’t work for some reason (version 2.0.2 from the store)

image

These are my settings:

Sadly, I’m still unable to get it to work as well. I’ve tried all of the fixes, but still nothing happens when I click the extension. I will definitely keep trying and checking back. I’m hopeful that eventually I’ll be able to figure it out!

@4183R7 @poploser It looks like your both testing it out on the PasteBin page which is good, did you confirm with the 2nd post in this thread that the api key was entered correctly? Scratching my head cause no matter what I try I can’t reproduce your error.

What are your system specs? Browser versions? Any other extensions that could be interfering?

Note for others: the small orange circle under the Chrome Extensions icon is visible when you are using a extension you loaded yourself (from GitHub). In case anyone was wondering.

Thank you for taking the time to respond. It does seem strange that it’s working for all but a couple of us. Sadly, I don’t have enough knowledge to do much troubleshooting other than following the advice in this thread. But no luck so far.

I double-checked for extra spaces with the API key. I tried turning off all other extensions. I’m on a relatively new MacBook Pro. Chrome version Version 89.0.4389.114

There must be something interfering. If anyone has any bright ideas of what else I should try, let me know! Fingers crossed I’ll get it working eventually!

Out of those that have a issue, I wonder if anyone else is running on Mac. Not sure as to why that would be issue or not. But would be interested in knowing. Myself and a few others that I know of have this working are on Windows 10.

Yep, also on a Mac and not working:
MacBook Air (M1, 2020) running MacOS Big Sur 11.2.3
Google Chrome 89.0.4389.114

I also got this issue on Windows 10 [Pro Version, 10.0.19042]:

  • I use the Brave browser [Version 1.22.70 Chromium: 89.0.4389.105]
    (all Chrome extensions work here but I also tested it on “normal” Chrome [Version 89.0.4389.114 ])
  • No whitespaces in API key ect.
  • Version 2.0.2

Thank you for your time :slight_smile:

I have tested the app on my home PC and work PC both running windows 10 and the current version of chrome. I have also tested it in a VM with a fresh install of Windows 10 and Chrome getting similar errors to everyone above.