Wanikani Real Numbers stopped working

Hi WK friends,
I just noticed in the past two days that WK real numbers stopped working for me. I am using Google Chrome. Here’s the link: https://greasyfork.org/en/scripts/by-site/wanikani.com?site=wanikani.com&q=real+numbers

Any ideas? Thanks!

Still works for me, do you use Tampermonkey?

Do you see any messages in the console (Ctrl-Shift-J / Cmd-Opt-J)? I only real possible problem in the script I can see might be a problem with your WK API key.

hi @ acm2010

Thanks for the time reviewing my concern. Yep, I am using Tampermonkey. So to sort things out, I disabled the rest of the scripts except for WK real numbers, and relaunched Wanikani. I pressed Ctrl-Shift-J and see this. Not really a dev guy so I am not sure what does it mean.

image

Did you change your API key recently by generating a new one? The “unauthorized” line means that WK doesn’t want to give you your real number of reviews :slight_smile:

You can try to clean up the API key and fetch it again from WK.

Type the following into the console (this deletes the local key the real number script got previously):

localStorage.removeItem("apiKey")

then reload the WK dashboard, and then there should be a popup “WaniKani Real Numbers has no API key entered!”, and when you press OK you will set it again with a correct/new one.

2 Likes

Yep I did change my API recently. Just followed your suggestion and it works now. That was sleek! Thanks a lot man, I hope I can send you some takoyaki and yakiniku :slight_smile:

BTW, what programming language is used? Is it Javascript? Sorry for the asking, not really well versed in dev world.

Yes

Glad it worked! Ideally the script should take care of such problems itself, it was detecting that it had an API key problem but didn’t do anything about it :slight_smile:

1 Like