[Userscript] WaniKani Review Clock

Hello! Thanks for responding so quickly. Unfortunately, those are all the errors in the console. I have done some debugging myself this morning, and I think I found the issue, and I’ll try my best to explain it.

  1. Yes, correct.
  2. I am using Firefox 112.0.1 with Tampermonkey.
  3. These are the errors with the arrows expanded with the problem-causing extension loaded (more on that later):
  4. That, unfortunately, didn’t help.
  5. Yes, when you run the user script by itself, it works just fine.
  6. Same issue if the problem extension is loaded.

Now, time for what I found. I first tried disabling all other scripts instead of User Clock, and to my surprise, User Clock worked just fine. After that, I tried enabling scripts I used little by little at a time. Then, I encountered the issue again. I found one script that causes this script to break is Reorder Omega. I have zero ideas why Reorder Omega breaks this script, but it seems to, at least with my setup and system.

I hope this helps, and thank you again for wanting to fix this script!

1 Like