[Userscript] WaniKani Pitch Info

Hii, anyone know if similar is available in any of the android apps?

You can download kiwi browser for android and install the violent monkey extension and then just install this userscript like you’d do on pc

2 Likes

Another option would be to add this over the input section where you wrote your answer in hiragana anyways.

Alternative you could also use a minimized version with bars like in the takoboto dictionary app.

1 Like

2 things:

  • I absolutely love the new update of showing the pitch info while you do reviews. That is amazing and 10/10

  • When I am doing lessons now, I no longer have any pitch info show up under “reading” tab. This was my spot to initally learn the pitch with each new word.

Am I doing something wrong? It’s been working while doing new lessons up until very recently

Is it still an issue after the 0.76 update I pushed today?

I made some changes so this will also work for Chrome, as the settings were not working for me. It also won’t nag you if you don’t happen to use the framework, you’ll just miss out on the option.

1 Like

Sorry! I didn’t realize that my commit caused issues.
My pull request was what I was using on Chrome (ViolentMoney), so it’s pretty strange. :thinking:

Unfortunately it is still an issue for me…made sure to double check that I was on 0.76. I did a few reviews and “Extra Practice” and had the wonderful new pitch information showing up during the reviews…however, when doing “new” lessons of vocabulary there is no more pitch info under the reading tab! :frowning: Let me know If I am missing something! Thank you for your hard work! Pitch Info has been essential in my WK journey since day 1!

Are you starting your lessons through the lesson picker? Then the problem might be that wkof.Menu.insert_script_link() throws an exception while on the lesson picker page (@rfindley, in case you want to look into this).

@Invertex I have wrapped that call in a try/catch block for a quick fix, but I don’t know if you have other plans to address this issue. Sorry for taking advantage of my write access to the git repository :sweat_smile:

1 Like

Bingo! That is the source of the problem. If I use the lesson picker, I get no pitch info under the reading tab, but if i do the “daily 15” and let it auto sort for me, then I do see it. However, previously I was using pretty much the lesson picker exclusively, and I could still see pitch info. It does seem to be a new issue, related to the lesson picker.

Then your problem should be fixed in version 0.77. wkof.Menu.insert_script_link(), which was causing the problem, was added two days ago, so it makes sense that it was working until recently.

1 Like

That is indeed, the fix. Thank you so much for working so quickly. It’s perfect now!

1 Like

Nah that should be a fine fix for now, thanks!

And no worries lol, you got write access for a reason!

Thanks for all the work you’ve done on keeping this script going :sparkling_heart:

1 Like

I appreciate the update with the settings!

Just a couple other small suggestions.
image

First, from what I understand (without having looked into it directly, myself), script authors get to decide the menu name and most of the scripts so far utilize one of the first two words (shown in the picture above) for the initial category depending on the purpose.
Would be nice if this went into the Settings menu as well.
Edit: The above is implemented. Thanks again!

Second, an additional setting to show/hide the one in the Reading area would make it feel more complete.

1 Like

Heya, I’m using the latest version and for some reason the pitch is not showing up at the top bar next to the vocab. I think it worked last week, but I’m not sure. It still shows up in the Reading tab below but not in the area above, if that makes sense.

There’s an option for it now, and it’s not on by default. Did you check the options cog at the top left of the reviews and check the box in it to turn it on?

My bad, it works now. I guess it just randomly turned on for me once and then turned itself off somehow? It’s a really nice feature, thank you!

1 Like

Ah no, it’s just that when the change first got pushed it was on by default and there was no option to turn it off.
But then an option was added and made off by default!
Sorry for the confusion.

1 Like

It’s all good! The feature’s great, thanks a lot!