[Userscript] WaniKani Katakana Madness

Thanks, I’m aware. However, I want to practice typing as well as I don’t want to rely on an application feature. Other websites and programs do not automatically convert western keyboard layout typing into Kana.

Thanks!

1 Like

Great script. Definitely helps me quickly to sort out if WK lists 訓読み or 音読み reading for its Kanji. Thanks :+1:

You can convert your candidate into katakana with Control-K. Control-J converts back to hiragana.
Nevermind that doesn’t actually fix your problem. However Google’s Japanese IME let’s you swap the input method to katakana, which seems to work fine with this script. It uses Romanji input by default, since that’s how most natives type apparently, but can be changed to kana input.

Also, Google’s IME is having no problems getting dakuten onto the katakana even when I leave it set to Hiragana. :thinking: So that’s convenient.

Hi! I just started using this script and it seems to not be working with jukugo words. For 入力 it shows the hiragana にゅうりょく instead of katakana. Is there a way to fix this?

The script is only intended to effect kanji, not vocabulary.

I see. That’s unfortunate, but thank you for replying!

I think there’s a compatibility issue with the current version of WaniKani and this script as it is. I was doing my lessons, and WaniKani was marking absolutely everything wrong, despite me typing in exactly everything as is in the answer bank. I turned off this script (out of the 11 I always have running during my lessons), and everything was smooth sailing. I also did the opposite and turned off every script except for this one, and the issue persisted. I don’t believe this affects reviews, and I’m not an experienced coder, so I can’t be 100% certain that the problem necessarily lies within the script. I really love this script, so if anyone has a solution, I would greatly appreciate it :smiling_face_with_three_hearts:

8 Likes

Thank you for identifying the script that was causing the issue! I was experiencing the same issue, but couldn’t figure out which one of the scripts was the source.

3 Likes

Script seems to have broken on the lessons page with the latest version of wanikani. Still seems to work for reviews though.

Is the author still active?

2 Likes

Came here to report this same issue! Every time you answer a question in a lesson the page goes back to the loading screen and the lessons start over.

Posting here just to get notified when a fix comes by :stuck_out_tongue: I like this script, would be a shame to not have it anymore.

1 Like

Same, I also encountered this issue recently and I like using this script, so hopefully there will be a fix eventually.

The good news is, as long as you add https://www.wanikani.com/lesson as an exclude in the script settings, you can still use it for reviews and individual kanji info pages.

4 Likes

Dafiretruck? IDK why I never looked closely at the options available in Tampermonkey’s dashboard. It seems that it is, much like a stricken down Ben Kenobi, far more powerful than I had possibly imagined.

I’ve been manually toggling multiple scripts off during lessons and on during reviews. Thanks for enlightening on this boomerism.

Technology

1 Like

Is there an app which shows full katakana?

It seems a bit unclear if the original author is still around (probably not). I decided to take a crack at fixing the bugs and improving the script a bit. It was pretty tricky, and I am not convinced I didn’t break something but here is the result:
https://controlc.com/20bffc14
To “install” it you’ll have to choose edit the script you have installed , and replace the whole thing with the paste on controlc. Consider it an open beta that I’ll probably release publicly if OP keeps being absent (and no serious issues are found).

changelog:
Fix lesson reviews not working
Fix n+space becoming ン as expected in on’yomi reviews
New Feature: Display reading with katakana also in the mnemonic text during lessons, and not just in the sidebar.

6 Likes

I tried it on mine and tried 10 lessons today, including several kanji that showed the katakana. It seemed to work fine for the limited amount of testing.

Just tested it and it works perfectly! Thank you so much!

Good job. One thing though, it doesn’t automactically change N to ン when I press enter. So when I type “シN” WK rejects my answer until I type one more N.

Yeah. I tried to fix it but I don’t know how. It gets stopped by some other script on the page and I am not savvy enough to decode all the wk scripts and find out which one it is so I can override it. It’s especially weird because it only doesn’t work on the lessons page, in reviews シN+enter is accepted.

For now you have to type NN or "N " (N+space bar). Or small n’s.

1 Like