[Userscript]: Double-Check (Version 2.x)

  • Starting from this version, the script now uses the Open Framework.
  • The script adds a settings menu, so settings no longer need to be configured in the code itself, and your settings won’t be lost when you upgrade to a new version.
  • This also fixes some audio issues, where audio was being cut off when advancing to the next question.
4 Likes

It’s nice that you mention me even though it’s your own code, Frankly I don’t care if you do use my code, although I tend to think your code is structured much better than mine.

Yeah, I figured it was time to start a separate thread so I can post updates in the top-post… mainly because the script integrates several other scripts (Lightning, Mistake Delay) to prevent conflicting code on the reviews.

Concepts count :slight_smile:
Quite a few of my scripts started with someone else’s idea. And sometimes with some else’s code.

1 Like

My Double-Check was the natural evolution of the scripts that made wrong answers correct, I just felt it needed the ability to be honest about “right” answers too, something the other scripts didn’t do.

3 Likes

I’m still surprised by the number of people who are unaware of Double-Check, despite how long ago you created it. “Override” is so ancient now, but it seems many people still recommend it when noobs complain about typos.

4 Likes

At least it’s gotten more attention than [UserScript] WaniKani Never Wrong*

So there’s hope for humanity yet.

5 Likes

Koichi should just hire you at this point.

3 Likes

From your lips to his ears, hehe :grin:

Work is slow where I live for software engineers, unless I want to move closer to Atlanta… which I don’t.

4 Likes

You’re tellin’ me. I work for Big Corporation and spend half my days just waiting around for other people. Despite the fact I have to wait 2 weeks for an EC2 instance, our company claims to be Agile.

1 Like

Heh… Unfortunately, sometimes ‘agile’ is a euphemism for “I don’t have a release plan”. Some do Agile well, others just like buzzwords.

re: slow work
I’m self-employed. I worked for (as an employee) and with (as a contractor) the same company for 20 years, but now they’re in a budget crunch, so very little work. I do Embedded Systems software, which is a field in need of more workers, but the work tends to be in hotspots, and I’m not quite near enough. My resume is stellar, so I get tons of calls from recruiters every week, but I’d either have to commute 90min, move closer to the city, or contract away from home for 6 months at a time… none of which I’m willing to do. But I have alternate plans, so I’m okay. Nonetheless, I do take on work when it comes up.

1 Like

In our case agile means follow the processes without actually changing anything. Continuous integration? Unit tests? What are those?

I’m trying to see if I can nudge my way into something that would allow me to work from anywhere, such as Japan heh heh. I may not be a wise master like yourself, but I can do alright if I’m not stifled by all of the bureaucracy.

If my “alternate plan” doesn’t pan out, I’m looking at adding a few key skills to be able to tap into the remote-only market. Either some major web-oriented application frameworks, or a bit more experience with high-speed FPGAs (a very niche area of electronics that is in very high demand)

1 Like

I…edit text…and sometimes pictures…
I can do more than that…but they don’t let me…

1 Like

Have I ever told you how awesome you are, @rfindley? Thank you for all that you do!

1 Like

Has anyone been able to get this to work in Safari? It’s not working for me. (Version 11.1.1)

Double-check is still not working. I have retested it several times with Chrome and Safari. Here were the TS steps:
1- reinstalled Tempermonkey
2- reinstalled open framework
3- deactivated all non essential scripts
4- reinstalled double check
5- tested functionality

The script doesn’t seem to load. There is no settings icon in the upper left hand corner of the screen when you enter the review mode. I really loved this script, hopefully this info can help to get it working again.

Do you have the Open Framework running as the #1 script in TamperMonkey?

Hello thanks for the quick reply, yes it is at the top first position.

Please let me know if there is anything I can do to help.

Are there any errors in the Javascript console? (In Chrome, press F12 and click on the Console tab)