[Userscript]: Double-Check (Version 2.x)

Nanori. Screenshot from the kanji 大

nanori

1 Like

I tried installing double check on a different computer today, but it won’t activate for some reason. Tampermonkey says it’s enabled and currently running when I do reviews, but I can’t use any of the features- active or passive.

Edit: this is on Chrome

Perhaps it is because nothing never shows up unless you are actually doing reviews. In the review screen there should be additional buttons on the right of the button bar at the bottom of the screen. There is also a settings option on the top left corner of the review screen. Can you confirm whether you see this?

1 Like

I was doing reviews…

No additional buttons appeared. I only had the home button in the upper left as well.

2 Likes

In this case @rfindley intervention is required.

1 Like

The usual steps:

Press F12 and click on the Console tab to see if there are any errors.

2 Likes

Tagging @CDR-Strawberry because rfindley has responded.

Thanks! I’ll try it next time I’m on that computer.

@rfindley I do get an error message,
image
Tampermonkey is enabled though :confused:

Interesting that rfindley didn’t include a check for WKOF in this script.

Anyway you need to install WKOF

4 Likes

Ahh, thank you! I completely forgot it existed.

1 Like

Yeah, I probably should do that. I think, at the time, I was doing a speed-patch when WK changed how subject_ids worked.

2 Likes

Hi @rfindley

I observed an expected behavior with this script, that may need a fix.

In the case where the english meaning is a transcript of the japanese word (eg. ‘納豆’ ‘幕府’), it seems possible that the script will just shake and not error out when the japanese spelling is typed incorrectly.

In my particular case of today, I typed incorrectly ‘なっと’ for the reading, and it just shoke, and did not give an error. The correct spelling is ‘なっとう’.

1 Like

It’s because “natto” is also the accepted Meaning, and when you have “Allow typos” enabled, it warns when you’ve entered the Meaning instead of the Reading.

I’m not sure what settings you have, but I’m seeing the pop-up message “We’re looking for the reading, not the meaning”. Are you not seeing that?

2 Likes

Thanks, you mean that this symptom happens only because I typed ‘なっと’ which happens to be the correct spelling of the meaning answer, even if WK was asking for the reading. It makes sense.
My settings were as below:

1 Like

Sorry if not entirely on topic but is there any place where wanikani typo detection is described?

I just can’t figure out why “police office” is not a typo for “police officer”, is it because it is a possible translation of another word from the vocabulary?

1 Like

They use the Levenshtein distance

But this is not the whole story. They also check the contents of an allow list of permissible answers and a block list of banned answers. If you want to consult the contents of the allow list and the block list it is available in Item Inspector. (Disclosure: I am the author of Item Inspector)

2 Likes

Thank you, will definitely check Item Inspector, I have some understanding of Levenshtein distance but allow and block list are news to me for sure!

Just a small thing, but since we don’t get a “Correct” notification in Lightning Mode, an optional satisfying ping sound would be nice! :smile:

Thanks for setting this up