[Userscript] An Unobtrusive Kanji Stroke Order

For some reason, it’s not working for me. I am using the 1.2.1 version and have the font installed.
Could it be jitai(the script that randomises the fonts)?

Yes same here. All latest versions installed but can’t get it to work on Mac Safari

@LevelUp, how did you install the script on Safari? Which userscript manager do you use?

@Xenon1345, what OS, browser and userscript manager do you use?

Are there any errors in the browser console?

Thanks fr the quick response @atzkey
I simply double-clicked on KanjiStrokeOrders_v4.002.ttf and then ‘Install Font’
I see the font in the ‘Font Book’
Am using Tampermonkey on Safari on Mac

The font link isn’t working:(

https://drive.google.com/uc?export=download&id=18Md7qnTJUJ3egywmCH12b9Gxk54FVVxP

Anyone know how to get this to work on Safari on a Mac?

Thank you!:slight_smile:

Sorry for the late reply.
I use Windows 10, Chrome and tampermonkey.

It is not working for me with Safari 13.1 and tampermonkey. Strangely, the installed font seems to work everywhere else, and when I force the style element to be added anyway (ignoring the script’s “isFontAvailable” check), it creates an interesting stylized kanji that when copied and pasted into Word renders the correct KanjiStrokeOrder font

I used “WhatFont” to verify that Safari is rendering “Hiragino Kaku Gothic Pro” rather than “KanjiStrokeOrders” when I try to use KanjiStrokeOrders. Can’t figure out why Safari, alone of all the apps on my system, can’t see that font

since everything works in chrome, might just have to stick with that

IS GOOD

IS BIG GOOD

NICE GOOD SCRIPT GOOD

IT GOOD

BIG THANK

2 Likes

If the script is working, but cannot load the fond, this is how the error is displayed: displayed:

anyone know a way to get the “reading” into Stroke Order font as well?

Is this script still being maintained? I installed the script on Firefox and the font, but I keep getting the message at the top of the page to install the font.

I disabled Firefox’s enhanced security settings for WK, but it’s still not working. Console output is below:

I’m guessing that the resource that is being blocked from loading is the font?

I had that kind of problem with Chrome. Closing the browser and restarting it fixed it.

I use this script all the time, and look after it, so I guess it could be said that it’s maintained. Errors in your console output seem to be unrelated to this script.

The Unobtrusive Kanji Stroke Order doesn’t load fonts from anywhere (it uses the font that you yourself loaded and installed on your computer), doesn’t evaluate any external scripts, and doesn’t make any external calls to the internet, so it’s one of the securest scripts out there. : )

I just tested it on Linux, Mac OS and Windows in FF and Chrome, and it worked everywhere. What OS do you use, and what version of Firefox?