No audio for most [yes the purple] vocab

TL;DR: Check windows sound settings, play the test audio with right clicking the device. If you don’t hear sound for the full duration of the animation, some channels are not working. Update your audio drivers.

Warning, major wall of boring text ahead:

I just spend half an hour trying to figure out why I was not getting audio on many items - initially I thought not every vocab word has audio, but as more and more did not play I figured out something is wrong - after all, I’ve reset from Level 15 and Audio used to play.

Long story short: It was the fault of my audio drivers. After letting Windows update install Realtek audio drivers (automatically after pressing update), it worked.

Initially I tried disabling scripts, then I tried another browser, then I checked out the files and found out that there is both a .mp3 and a .ogg for (most?) the audio. It would play the mp3 per default, apparently. I downloaded both files and found out the mp3 did not have any sound. I tried an online converter, which succeded, so I figured my computer just doesn’t play the mp3. I thought the codec was missing since it would play in VLC which uses its own codecs afaik.

So I downloaded a Codec pack with many settings (the K- something one, not the adware), but that did not help. After some searching, I tried my USB headphones and surprisingly there it played perfectly. I then dug through the windows sound settings, where I made the discovery that although my speakers would work perfectly with Stereo, something was odd: when I use right-click test on the headphones, 2 sounds would play, the green light thing lighting up for that duration. If I did that on the speakers, those 2 sounds would too play in stereo, but the green indicator would continue to indicate inaudible sound was playing for like 3 times the normal duration of that 2 initial sounds. I tried resetting settings, to no avail.

At that point I went to windows update to install the Realtek drivers that failed to install last time, after Windows update decided to download them due to me removing the drivers that came with the mainboard, since those were not good for recording audio (actually removing them did not help in the end, using an USB microphone did). After that, when clicking Test on the speakers, the 2 sounds would play the same as before but the indicators would stop after the 2 sounds, just like on the headphones. The mp3 file now plays and so do the reviews.

Anyway, I wanted to share this perhaps more mysterious problem and solution if anyone else cannot figure out why some vocab is not playing. The strange thing was I never noticed any other issues with my speakers for at least a week since I’ve removed those drivers. I’d like to mark this as solved but don’t know how.


Thank you so much for posting this. I was having the exact same issue and this helped fix it. :slight_smile:

1 Like

Mark one of the responses as solution

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.