Context Sentences - Audio

Hello Wanikani team,

I am a total newbie and I am enjoying my experience thus far. However, here is some feedback that could improve the Wanikani user experience.

I wish there was audio available for the context sentences. It would make me want to listen while reading the sentences and perhaps repeat them out loud. Right now I find myself skipping the examples and focusing more on the root memorisation of the Kanji, looking up the mnemonics for those I find difficult to memorise.

Thank you for your work!

Regards. :blush:


You might enjoy this userscript: [UserScript] Advanced Context Sentence


Thank you for the tip! :slight_smile:

They are unlikely to add official audio to the context sentences, because they hire professional voice actors for the audio and there are thousands of sentences. It’s just not a good bang for the buck from their end. Additionally, they often get feedback on tweaks that are needed to context sentences, so they aren’t static like the words themselves are.

1 Like

Hello again! :slight_smile:

I am sorry to bother but I cannot make the script work. I installed everything following the guide step by step and still, when I am doing the lessons there is no option to listen to the example sentences.

Is there anything more to installing the script?

Thank you in advance!

Do other scripts work for you / have you installed any other scripts before? You should get the Tampermonkey extension for your web browser and then it should relatively easy to add new scripts

Also make sure your installed scripts are not turned off (in that screenshot Golden Burn is turned off)

It is the first time I install scripts.
I am using Chrome and I installed Tampermonkey just like the guide suggested.
I really do not understand why the audio icons do not show up… :frowning:

Well, it looks like you didn’t install the actual script you wanted to install in the first place yet :stuck_out_tongue:

Damn it… Sorry about that.

Thank you so much for the help! :sweat_smile: :innocent: :wink:

1 Like

Just installed it and it still does not work… I’m starting to feel really stupid. :sweat_smile:

So if you, for example, go to the vocabulary page for 大人, you don’t see these speaker icons next to the context sentences? Can you look if the console of your webbrowser shows any relevant errors? In most browsers, you can open the console with Ctrl+Shift+I or just with F12, and then there should be a tab “Console” (as marked in the screenshot below). Maybe you can post a screenshot?

Hi! :smile:

Sure, here we go. I do not understand why it doesn’t work… Could it be a clash with any of the other extensions? I have Adblock, Video Speed Controller and a couple of others.

Thank you so much for your help! It’s much appreciated!

The number of errors keeps increased for no apparent reason over the last minutes…

Those errors seem to be related to the service WaniKani uses for handling payments (stripe) and are not relevant for your problem.

However, I just created a new WK account for testing purposes, and it seems that the Open Framework doesn’t automatically generate an API token. So you have to do that manually:

Go to the settings page for your API tokens and click Generate a new token. Enter any description you want for the token (maybe “wkof”, because it will be used by the WaniKani Open Framework). You don’t have to grant any additional permissions, so you can leave all checkboxes unchecked, and then click Generate token.

EDIT: Weird, now that I have tried it again (by expiring the token I have created manually), wkof immediately offered to create a new one which worked flawlessly. I’m wondering why it didn’t work the first time. In that case, if your API tokens setting page already looks like in the screenshot below, then this also was not the problem and we have to keep investigating.

1 Like

Hi again!

I’ve just followed your instructions and still no success… This is really weird. Did it work on your test account? I uploaded the screenshots for you to see that no audio icon shows up at the end of the example sentences. :unamused:

Thank you so much for your time and help thus far! :heart:

After realising that I posted my API token I deleted that it and created another code with the same name… No success again. :roll_eyes:

And if you are on a vocabulary page and click on the Tampermonkey icon, it is enabled and shows that Advanced Context Sentence is active?

I’m slowly running out of ideas why this could happen. You could again open the webbrowser console and type in wkof just to test if WaniKani Open Framework is properly executed and available. What webbrowser are you using?

1 Like

IT WORKED! OMG! :sunny: :heart_eyes: :sweat_smile:


***Our little secret… Tampermonkey wasn’t enabled. :stuck_out_tongue: I know I’m bad with computer stuff. :sweat_smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.