Audio Delay - Attribute or Quirk?

It is great to hear audio for vocabulary in Wanikani. I let it wash over me, imagine it sinking in to my mind caves for future recall.

However audio plays once the relevant kanji has disappeared. In my experience it plays around 0.5 of a second after the next item to be reviewed has appeared.

My fear is that as I decipher the new kanji in front of me, my brain will somehow erroneously connect it to the audio still playing from the previous slide.

  • Is this paranoia reasonable?
  • Is my browser being sluggish?
  • Is it actually a clever and intentional learning feature of Wanikani?
  • Is it an ongoing server issue that the correct people are aware of and are actively working to resolve?
  • Is there a workaround or fix that I can do to improve the situation?

Thank you, and I’m new here, so be gentle if I did something wrong! :honeybee:

1 Like

I have the same thing with the delay. If you are afraid of this effect, maybe close your eyes when you go the next review and really let the image linger in your mind.

1 Like

I think that might be a bit paranoid :wink:

I’ve noticed it, sometimes worse than others. I assume it’s just whatever delay in downloading/loading and playing the clip.

You can of course just wait a second before moving onto the next card…

1 Like

When I have a delay, it is always because my internet connection is a little slow. :slight_smile:

Yah. Just internet lag.

Or don’t go to the next review until the audio plays.

I just turned the auto-audio off for lessons and reviews because I found the delay so annoying. It felt like waiting for the audio to play slowed down my reviews too much even if it was only a few seconds.

Also I find one of the female voices to be super irritating as it’s very slow, breathy, and weak. The other voices do a much better job of enunciating.

I found this annoying too so I created a script to solve this:
https://greasyfork.org/en/scripts/387245-wanikani-no-audio-delay

please tell me if it helps!

I just hit “J” before enter to hear the audio.

I was really hoping this would work for me, but I’m afraid it didn’t. Audio still played after moving on to the next review item. I’m on Safari with a fast internet connection if that helps.

Thanks for giving it a try.
Right now the script only pre-cache the audio files to reduce the delay (so if you have fast internet you will see less improvement. For me sometimes audio was played with 1s+ delay because of downloading), I think this can be improved more so I will keep investigating. Maybe next version will be helpful to you :slightly_smiling_face:

1 Like

I’m having this issue as well, with no browser extensions enabled in WaniKani. It only happens 1/10 times, but often enough to be frustrating. I’m wondering if it’s due to the browser cache getting full up after doing too many lessons/reviews a day.