API key not registering on userscripts

I logged on today and found I am having an issue where I am being asked to enter in my API key. It says:

It seems you haven’t generated an API key yet.
Please click [here] to generate one automatically.

So I generated a new API key, but it keeps coming up with the same error on all the userscripts I have installed.

How can I fix this?

(I am using Wanikani Real Numbers, Wanikani Ultimate Timeline, and Wanikani Reorder Ultimate).

you need to input the API key into the userscript, no?

I found that with Tampermonkey on Vivaldi, (a chromium browser), that I had to disabled strict mode for the userscripts to work.That was just earlier today.

How do I input the API into the userscript? I’ve never had to do this before.

That’s probably because the settings page changed.
Means the scripts need to be updated to fetch the key properly again.

Oh, I see. Thanks :slight_smile:

The WaniKani Real Numbers script has the same issue, I just disabled it for now. I did apply the script fix to the Ultimate Timeline, but it looks like it might have been updated just now already.

yep, I found the problem on the Real Numbers.While an official update is launched, I have made myself a quick fix. We need to modify only one line.

@Jaiced I think I solved the problem in the WK Real Numbers script. Please verify this. I’ll be updating my other scripts now.

1 Like

Sorry, just saw the message now. Yes it works, thanks :slight_smile:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.