[Userscript]: Double-Check (Version 2.x)

It works just perfectly now, every feature I missed is there :smiling_face_with_tear:

Can finally go back to doing reviews now that open item info on fail and retyping mistakes work now…


Works perfectly on Safari. I always had faith because you are ‘the one’. Thank you, this has changed everything. I was grinding to a halt and it was all falling apart. Thank you, thank you thank you. :two_hearts:

1 Like

It appears to be working perfectly today :slight_smile: Not sure if it’s the latest update or not.

Still broken for me :frowning: Either I don’t see any of the UI or settings, or the setting and UI show up but then any answer is allowed, right or wrong. Safari Version 16.5 (18615.2.1). I’m also noticing that despite me having lightning mode off, it is automatically going to the next review item regardless.

1 Like

Thank you very much for the updates :slightly_smiling_face:

I noticed a problem with the SRS level indicator displayed during the review sessions. Once the reading and the meaning of a given item are both answered correctly, the SRS level indicator pops up two times, before AND after we move to the next item in the review session.

EDIT : I am using Firefox v. 111.0.1


Maybe you could go through the suggested steps in this guide to gather more information about your problem and post it here.

Weirdly enough, the script started working for me today after a few reloads but only for one review session. When I did the next one a few hours later, it was gone again and the ‘quiz_queue.hasSubjectIdsWithSRSTarget’-error still showed up in my console.

So, I decided to upgrade my macOS to a more recent version and update Safari from 15.6.1 to the latest version 16.4.
Lo and behold, the Double Check script worked! (I’ve only had 2 review sessions since my update but it seems to be working consistently now – the update probably fixed my issue.)

Thank you, again, for all the troubleshooting advice you’ve given me as well as continuously updating the Double Check script! :smiling_face_with_tear:

1 Like

Huh, that’s a neat page (never saw it before you pointed it out). I’ll try to pull something together later tonight after work and Japanese class.

Happy to report it is working correctly for me! I appreciate all your hard work and wish you the best.

It would be nice if Typo in meaning : Warn/Shake (No Cigar) has a backup handling.

  • Press Esc to mark as wrong (regardless of Typo in meaning settings)
  • Mark as wrong button
  • Shift + Enter to allow typo parsing

I noticed a bug that (I think) appeared in v3.0.7, but wasn’t yet in v3.0.6:
The SRS-Popups now always appear twice, regardless of if you answered the review normally, or retyped / marked the answer wrong or false. Running on Safari with latest MacOS.

EDIT: Just noticed that another user has pointed it out on Firefox as well.

Also, the script currently runs even on the forum. Probably want to change the match line to

// @match        http*://www.wanikani.com/*
// @match        http*://preview.wanikani.com/*

Thanks for the latest update. I’m still having a bit of trouble with SRS popups not appearing in lightning mode. Seems to be caused by answering a second question (which would like to show SRS popup) while the SRS popup is still being shown? But I’m not sure, it’s tricky to reproduce.

I’ve updated to the recent version and for some reason the second item automatically gets an ‘undefined’ answer. I’m unable to delete this answer (I’ve used backspace or delete). Reopening the browser does nothing.

Thanks so much for the script. It’s making Wanikani usable again for me after the latest update.

Would it be possible to add the ability to have an incorrectly answered item be put back into the queue and asked again rather than simply retyping it? The option to skip an item and have it be asked again later would be great too. I often find myself stuck on a single kanji/vocab item but if given the chance to come back to it I can easily answer it.


I came here to report that I have encountered the same issue, on Chrome Desktop.

1 Like

Okay finally figured out what was going wrong. Apparently the simple script I was using to hide the review accuracy causes Double-Check to malfunction:

// ==UserScript==
// @name         Hide Review Accuracy
// @namespace    http://tampermonkey.net/
// @version      0.0.1
// @description  Hide the review accuracy in the top right during review sessions
// @author       me
// @match        https://www.wanikani.com/subjects/review
// @grant        none
// ==/UserScript==

(function() {
    'use strict';
    var percentCorrect = document.querySelector('[title="percentage correct"]');

This was my own attempt to fix up the Hide Review Accuracy script that hadn’t been updated yet (so I’m sure that I’m making some basic mistake), but I’m a bit surprised a simple script like this would cause Double-Check to go south. In any case, I’ve disabled this script for now and things are much better.


I noticed this as well. I am using Tapermonkey 4.18.1 with Chrome and tried with all other scripts disabled (other than Wanikani Open Framework) but it still gave me the bug. No errors in the console.

Edit: After further testing, I have discovered that this issue does not appear when you change the setting “SRS popup time (in seconds)” in the “Lightning” tab to 0. So I’m guessing that the issue is that that is being applied even when lightning mode isn’t being used.

1 Like

Yep. I had a few free minutes today, and I think I’ve fixed it, but I haven’t tested it yet. Should be released tonight.


Version 3.0.9 seems all right to me. Thank you for the fix :slightly_smiling_face:

1 Like

Thank you for updating this script, it helps to reduce frustration if used correctly. However, since the last update I have an issue: whenever Wanikani detects a mistake, it shows the correct answer under the answer box you write in. However, if I try to rewrite my answer, the correct answer box won’t dissapear, albeit with a white background instead of the read on, making it slightly annoying: