How to write the @#! japanese single opening quotation bracket 「

Since the beginning of the times I’ve been unable to type the opening quotation mark. I mean the single opening quotation mark used in Japanese: (「 )

However, I can type the single closing quotation mark ( 」) as well as many other marks and symbols used in Japanese.

I’ve been copy&pasting this symbol all this time but lately I feel it’s time to address this issue. I did some search but I couldn’t find a solution. So I thought maybe you can help…

I’m on a macOS Sierra and my configuration is:

55

11

15

As you can see, my Romaji Layout is Spanish - ISO but switched to ABC, Querty and other layouts and that made no difference.

Also, I don’t switch languages. I only use Japanese as my sole input method and switch from Romaji to Hiragana and viceversa. I have a shortcut configured to simply switch the layout by alt + UP or alt + DOWN which is very convenient and useful.

The thing is that when I try to type 「 using my keyboard I use the keys alt + [ but the result is: [

I get this:

But If I try to type 」using my keyobard I use the keys alt + ] and the result is 」as expected. I get this:

Please, help. :frowning:

I realize this isn’t going to be helpful, but are there not just bracket keys on Macs? I don’t see why this would be an issue at all from the perspective of my PC keyboard.

1 Like

https://www.coscom.co.jp/learnjapanese801/keytable.html

[=「
]=」

3 Likes

Thank you, anyways! I don’t know either. I couldn’t find any related info or people with the same issue.

I have a Macbook Pro with JP layout, input works with [=「, the key is to the left of the big Enter key on the right. If the key labeled [ on your keyboard doesn’t work maybe that key (with other label) does something.

If you want to experiment you can also look at this: https://superuser.com/questions/549697

Are you typing with the Romaji input or the Hiragana input selected? I’m using Sierra too, and I can’t get it when I’ve selected Romaji, but when I type [ or ] with Hiragana selected I can get 「 or 」

@MasterSenSenpai If I type: [ I get this:

…and if I type ] I get this:

21

I already tried all keys and combinations but the key for [ is supposed to be the one but it doesn’t work as expected unlike the key for ] which is printing the *japanese single closing quotation mark" as expected.

I don’t know what am I doing wrong…

are you typing with romaji? that’s your problem.

Use hiragana.

I’m typing with the Hiragana input selected but the Hiragana input offers me a great variety of full-width for the western opening bracket symbol. I’m also trying to type 」with ] and I used several different common layouts to make sure it isn’t a thing related to my Spanish - ISO layout for Romaji.

Please try Hiragana.

I use macOS Sierra and I don’t seem to have a problem typing「.

Anyway, if all else fails, try https://www.google.co.jp/intl/ja/ime/ (Google Japanese IME).

I do type with the Hiragana layout being selected. Like this:

Let’s say I want to type the following sentence:

私は「ひさし」という名前だ。

This is what happens:

41

I do use the Hiragana input… I’m not sure what’s wrong with my configuration. Does it look right looking at the screenshots from my Keyboard settings?

Thank you for the Google Japanese IME! I’ll consider it if I become super frustrated. :slight_smile:

take your Mac back to the apple store lol

seriously tho, don’t know… is weird.


try where it is on here?

other than that I have no clue.

1 Like

Not sure why that list of options window is popping up at all, it doesn’t for me. Are you hitting alt or something to make it come up? I just type [ and 「 appears, no window or anything. Romaji layout = U.S. btw

If nothing else works, you can do what I did below and force your computer to always autocorrect some combo like [* to 「

1 Like

The list of option shows up because I press spacebar just to demonstrate that 「 isn’t on the list. I used a lot “the list of options” to pick the right word written with the right kanji when writing in Japanese. It’s common thing to do, isn’t it?

Your workaround is nice! I’ll try that if I doesn’t fix this issue. Thank you! :slight_smile:

Not gonna lie, I haven’t actually typed anything in japanese in months and I totally forgot that you could bring that list up with space. Wow. Anyway, here’s what I get:

No idea why you don’t have it

Thank you for sharing your pop up “list of options for when typing [ while Hiragana input”. I’ll try to find why I have less options than all of you.

What type of keyboard is actually on your computer? I think the fact that you are using only the Japanese input for both Japanese and non Japanese (I assume both Spanish and English) is what is messing you up. When I changed my settings to exactly what you have setup I also could not type the opening quote character like I normally would, so its definitely your settings.

Here are some suggestions to try:

First, use the appropriate input method for the language you are typing in. Your computer actually uses separate dictionaries for the language of the keyboard you are using. This is why you see multiple keyboard layouts for the same language even though that might not be the default for that country. Using romaji to type in non-Japanese languages messes with what your computer assumes you’re going to be doing. You will still be able to use your alt + up and alt + down shortcuts to switch between languages exactly the same way as you can now. (assuming you set them as “Select the previous input source” and “Select next source in Input menu” in your keyboard shortcuts)

Turn off romaji input. The only option I have selected in my Japanese keyboard is hiragana. Chances are if you want to type in romaji, you aren’t writing just a single word in Japanese, so it’s better to use a different input. Use the Spanish keyboard for writing in Spanish, the flavor of English you prefer for writing in English. You’ll get many benefits unrelated to they keyboard layout.

For “romaji layout”, choose whatever matches the physical keyboard on your computer to make things simple.

To type an opening quote, press just the [ key, without alt/option. I think this is what is throwing you off. I see that on the Spanish ISO, you can’t actually type a [ without using option, but it might be bypassing the IME and typing just that character. Are you using alt + [ because it shows up as a backtick ` otherwise? That’s what happened to me when I switched to Spanish - ISO, like you have, for my romaji input. If that’s the case you’ll probably need a different binding for the opening square bracket key.

Finally, have you tried resetting the custom dictionary for your keyboard? At the bottom of the Input Sources menu the option is “Conversion Learning: Reset…” try that out. It should reset any learning your keyboard has done, and put it back to the default dictionary. I don’t know if typing in Romaji input mode in other languages can influence this dictionary, but it might happen.

@Mordoc,

Thanks a lot! I feel super relieved after reading your explanation. I understand what you mean by using the appropriate input method along with the keyboard I’m typing in. Also, thank you for taking some time to change your settings to my setup. :slight_smile:

I did exactly what you suggest but unfortunately the problem persists. My keyboard is Spanish - ISO and from now on I’m using the Spanish - ISO (Spanish) input source instead of Romaji (Japanese) for typing in Spanish. I also added Japanese and the only input mode activated is Hiragana. The shift key action is for Katakana and the typing method is Romaji.

When typing in Spanish - ISO I have to type “ALT + [” to type: [
If I simply type “[” I type a tilde: `

When Hiragana layout is active I get the same result. This problem only affects the [ key; it seems to be acting like Spanish - ISO is being active.

I also get rid of the Spanish - ISO layout and added English US instead but the result is the same.

I’m happy to know that could reproduce my problem but it seems that can’t get it to work following your indications.

Is there something I forgot to configure or did wrong?

Thanks a lot!

If I configure the Romaji Layout as US, ABC or other but not Spanish - ISO it works! :sweat_smile:

1 Like