Wrap Up Bug


So, everything working fine with the Wrap Up function.


Then we get to 0, classic Wrap Up.

Unless…

If you uncheck the Wrap Up option, you can’t advance.

Unless…

You check it again.

Is this considered a bug? :joy:

I guess it also doesn’t let you Unwrap Up once you get to 0.

2 Likes

Can’t replicate it, but I have no scripts on this computer.

Ah! I forgot.

I have the WaniKani Override script, let me turn it off.

Nay, the same thing happens with TamperMonkey off. :thinking:

Still using Google Chrome
Versión 76.0.3809.132 (Build oficial) (64 bits)

Tried it on Incognito, (where TamperMonkey isn’t allowed to be) and still nothing.

Now disabling AdBlock.

Same without AdBlock.

I don’t need to tag anyone, right?

Have you tried it on a different browser?

Agh. Different browsers. :confounded:

And also no script on that different browser. Who knows it’ll work.

So, Internet Explorer 11.

image

First, I noticed it didn’t like centering stuff.

Unless you got it right. (Or selected somewhere else in the page.)

image

Then that, according to IE, it’s fine to add spaces to Japanese.

Then the exact same issue happened.

Not being able to advance if you uncheck the Wrap Up option, as well as canceling said option when you get to 0.

I haven’t tried the ol’ reliable of turning it off and back on again, but I’m going to sleep soon.

I’ll check tomorrow.

I have never actually used wrap up, can someone explain what its used for?

If you don’t want to do all of your reviews in a single sitting, you can just leave the page, but unless you’ve been lucky, you’ll have a handful of half-completed reviews where you only answered one part of an item, or you got it wrong and it’s still waiting to be completed and have its level lowered.

If you don’t return and complete those items within a certain amount of time (like 2 hours or something) then they reset and it’s like you never did any part of them before. This makes more work for you, with regard to the half completed ones, and could even result in getting an item right that didn’t deserve to go up, because you only got it right from having been reminded in the previous session.

The wrap-up button consolidates all your outstanding items into the next 10 so when you stop you have nothing half-done remaining. When those 10 are done the session finishes automatically.

6 Likes

Oh wow that seems really useful, thanks for the info!

1 Like

So, the Android app I use had the same initial issue, only that it just got stuck on the review page even after reselecting the Wrap Up option.

Tried it on the WaniKani page on my phone, same issue.

20190903_073838

Same on this weird Samsung Internet I never use, but wanted to be thorough.

20190903_074825

The ol’ reboot didn’t work.

Hmmm, well, this is a long neglected bug report. :flushed:

We’ve known about this one for a bit, but it continues to be low on our dev priority list. We’ll bump it up a bit and take a look at it in the next few weeks.

4 Likes

I mean, it is completely avoidable, but it’s there. :stuck_out_tongue:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.