WK Real Numbers (userscript)

eggzakly said... Yay! got it to work - turned out to be a conflict with another chrome extension.
 Good deal! It took a bit of fiddling to get it working on my end too.

Userscript site doesn’t seem to be working. Does anyone have a mirror of this script? Thanks!

punjoop said... Userscript site doesn't seem to be working. Does anyone have a mirror of this script? Thanks!
 http://pastebin.com/ahWk3yNq

Thanks! I can’t see if it’s working or not, since I do not have any reviews right now, but isn’t it supposed to define the time till next review more clearly? It still says ~1 hour. I did enter my API key.

42+ again :l

punjoop said... Thanks! I can't see if it's working or not, since I do not have any reviews right now, but isn't it supposed to define the time till next review more clearly? It still says ~1 hour. I did enter my API key.
 That's /t/WK-Real-Times-userscript/1096/1 which shows 'real times'. In case you want that one too here's a mirror of it; http://pastebin.com/Kzkz3iqi

johnDoe said... 42+ again :l
Works fine for me. Maybe try generating a new API key and setting it.




Ah, thanks a bunch. Since it was discussed in this thread, and that one only showed pictures of adjusting the time on the forum, I just assumed it would be this one.

Great extension, but for some reason when I have no reviews, instead of displaying a 0, the gray circle is blank. The Dashboard and Level circles are also blank.

Does anyone know why Koichi won’t use real numbers? 42 has been kind of overused…there doesn’t seem to be any technical reason for this little annoyance.

Just gives me blank circles on Firefox 31.0. Additionally, I get a Javascript error from this script:

TypeError: (...).anchorSlide is not a function ...Anchor=t=function(){(“a”).anchorSlide({topOffset:-80})},this.Misc.bootStrapDrop…

It appears that anchorSlide is supposed to be a function but is undefined. I can’t get firebug to work with Greasemonkey scripts on this computer for some reason. Gosh, I hate computers!

This used to work fine for me, but seems to have stopped working after the latest update. Any advice?

Edit: it appears to be working again.

Vorpal said... Does anyone know why Koichi won't use real numbers? 42 has been kind of overused...there doesn't seem to be any technical reason for this little annoyance.
 I completely agree. I am as much a Hitchhikers Guide fan as the next, but it seems silly and unnecessary.

For anyone still having troubles with this: i’ve found the solution! (for my problem anyways, cant speak for others)

So i took the script from http://pastebin.com/ahWk3yNq because that userscript.org website doesn’t seem to be working on firefox. I also didn’t take the effort to read the entire history, so any solutions between the first and last page were lost on me.

My problem was that the script couldn’t find my API key. I did a quick search trough the code, inspected some elements and saw there was logical error somewhere. Not surprising that issues could come up if they change the settings page, due to the hacky nature of retrieving that API key.

So you just have to change

var apikey = document.getElementsByClassName(“span6”)[7].getAttribute(“value”);
into
var apikey = document.getElementsByClassName(“span6”)[6].getAttribute(“value”);
Anyone notice the difference in index? Yea, that can be a bitch sometimes. Coders will know.

On the link i provide this code should be at line 103, or just CTRL-F the thing…

Hope that helped for anyone still using this.



Thanks! I’ll give it a try.

Mempo said... For anyone still having troubles with this: i've found the solution! (for my problem anyways, cant speak for others)

So i took the script from http://pastebin.com/ahWk3yNq because that userscript.org website doesn't seem to be working on firefox. I also didn't take the effort to read the entire history, so any solutions between the first and last page were lost on me.

My problem was that the script couldn't find my API key. I did a quick search trough the code, inspected some elements and saw there was logical error somewhere. Not surprising that issues could come up if they change the settings page, due to the hacky nature of retrieving that API key.

So you just have to change
var apikey = document.getElementsByClassName("span6")[7].getAttribute("value");
into
var apikey = document.getElementsByClassName("span6")[6].getAttribute("value");
Anyone notice the difference in index? Yea, that can be a bitch sometimes. Coders will know.

On the link i provide this code should be at line 103, or just CTRL-F the thing...

Hope that helped for anyone still using this.



 THANK YOU FOR THIS. 
Mempo said...Hope that helped for anyone still using this.
 You, sir, are a scholar and a gentleman!

The download post from OP no longer works, so thank you for your fix, Mempo!

I’m getting no luck with this whatsoever anymore. I’m using Firefox 38.0.1 and have tried the version of the script from the above pastebin as well as from https://greasyfork.org/en/scripts/703-wanikani-real-numbers, both with, and without, changing the code as Mempo mentioned

I get the blank circles on any page and it seems to mess up the loading of other userscripts.

I tried adding an alert to see where the problem is, and it doesn’t even load past

var apikey = GM_getValue(“apikey”);
which is basically the first line of the main function.

Also, when I click the Greasemonkey icon and look in User Script Commands, nothing from this script comes up. This is kinda irritating.

How very strange…

I actually just reinstalled it on another computer to see if it was actually easy to install, because i wrote my previous comment after some fiddling with code etc.

But it turned out fine, really. I copied the code from the pastebin-link, made a new script by clicking ‘use script from clipboard’, changed the code (as i mentioned earlier), refreshed, and it worked.

I just checked and i have Firefox version 35.0.1 for Ubuntu. Kinda weird that you’re 3 versions ahead of me, so i’ll assume you use Windows or i just forgot to update for a long time (quite possible). Not that it should matter which OS or Firefox version you use (i guess?!), but i’m just saying it’s weird and i feel bad there’s no (easy) way for me to test this for myself. Since you said it messes with other scripts, i could advise to try and change the order of your scripts. Maybe give it the lowest priority, so it executes last?

Mempo said... How very strange...

I actually just reinstalled it on another computer to see if it was actually easy to install, because i wrote my previous comment after some fiddling with code etc.

But it turned out fine, really. I copied the code from the pastebin-link, made a new script by clicking 'use script from clipboard', changed the code (as i mentioned earlier), refreshed, and it worked.

I just checked and i have Firefox version 35.0.1 for Ubuntu. Kinda weird that you're 3 versions ahead of me, so i'll assume you use Windows or i just forgot to update for a long time (quite possible). Not that it should matter which OS or Firefox version you use (i guess?!), but i'm just saying it's weird and i feel bad there's no (easy) way for me to test this for myself. Since you said it messes with other scripts, i could advise to try and change the order of your scripts. Maybe give it the lowest priority, so it executes last?

 Soooo, thanks for this. What I had done before was just pasted the script text into the existing script that I downloaded before.

This time, I made a new script like you mentioned, pasted in the text, it asked if I wanted to overwrite the existing one so I said yes, and then I refreshed. I had to manually enter my API key (which it at least let me do this time) because it couldn't find it for some reason, but now it's working!

I'm not sure why it wasn't working before, but at least it works now.