Windows10 copy-paste messing up with CJK fonts

Hello,
have you experience this problem, and do you have a solution for it, please?

I tried to copy-paste from a Wiktionary article to my WK notes, but the japanese character for ‘promise’ (lvl14) always becomes the chinese version of it:

source URL:
https://en.wiktionary.org/wiki/確認#Japanese
image

paste result:
image

I tried multiple combinations, none worked as I expect :

  • using FF, copy from Wiki article to WK notes
  • using IE, copy from Wiki article to WK notes
  • using FF, copy from WK kanji details to WK notes
  • using FF, copy from WK kanji details to my webmail.
  • using FF, copy from Wiki to gmail
  • etc.

A similar issue happens on Android, and users of Flaming Durtle knows that they should add ‘japanese’ as a secondary language in their Android settings.
But if I add ‘japanese’ language to the Windows10 setup, it does not improve a bit (or maybe I need to reboot/relaunch browser?).

Is there any workaround for that? Thanks.

Cordially yours

Hi @Kumerei, would you know about this, by any change? Thanks.

No issue here, Windows 10, Chrome browser, and Japanese language support installed as secondary after English. Copy and paste with Yu Gothic as the font:

image

If you notice in your screenshot, the last character is a little different as well.

Why don’t you try copy/pasting into Word or something and specifically setting the font to Yu Gothic and seeing if you get the same result.

hi,
using one of the Firefox addons to show the fontname of displayed texted, i found:

  • the correctly displayed text in Wiktionary is using the Yu Gothic font.
  • the other sites which displays the chinese variant are using Arial, Helvetica, etc.

Should I select Yu Gothic as my default OS font?

ps: I guess the WhatFont tool is wrong, and it is not Helvetica. The OS certainly revert to some font which support (incorrectly) CJK codes when the character is not supported by Aria/Helvetica.

I’m not sure what your best course of action is, I’ll have to let someone else chime in. But when I copy and paste that into OneNote for example, for me it automatically changes the font to MS Gothic with the correct character support.

When I go into Windows language settings, I have it set up like this, didn’t have to do anything special:

Thanks, I have a similar setup, yet windows is selecting a Chinese font. Or a Chinese font is lying and reporting to be Japanese language, but I cannot find which one.

I tried in Wordpad and it properly copy/pastes as the MS Mincho font. I was able to replicate the issue and the resulting paste into Wordpad showed the SimSun font.

Capture

Pasting both into a plaintext editor and even on here showed the proper result for both.

What happens when you ctrl-shift-v to paste without formatting?

Thank you both.
I am not sure, but it is possible that relaunching Firefox after adding Japanese as a 2nd language fixed the issue.
I can now copy-paste the correct japanese characters in WK!
Regards

1 Like

>@Kumerei

4 Likes