Wanikani Reorder Ultimate [old version, not working]

kairu said... Completely nit-picking here but is there a way to save the review settings so I don't have to manually select them each time?

For example, say I like starting with Kanji first, then radicals, then vocab, from lowest to highest level, reading->meaning option.  Every time.  Is there a way to save that set-up so next time I load the page it automatically has my ideal settings selected?  That way the only time I need to change anything is if I want to switch up the reviews a bit.  I realize I am lazy but...it would be nice.  
 :P  I just edited my last post to say I was including this.  But yes, this is planned.  I can't really do anything about saving previous levels, but I'm sure people only use to for ascending order anyways.

Probably a silly question… but where is the wrap up button? (´・ω・`)

Edit:  Found it… Never noticed it was there! (・ω<)

I’ll just leave these here…



If you’d like to test: https://gist.github.com/xMunch/4610ed851cbf0264af2b/raw/7acb847bf234e6c6328178302de2f3744c89f5c2/WKU2-BETA.js
Not going to explain everything as it should be pretty self explanatory… Have fun messing with the scales :). 
I give no guarantees of features in 100% working form, though my 1 man testing seems to work pretty good for me.
Report bugs, I’ll be back in about 10 hours.  お休みなさい。

The beta version is not allowing new reviews to load after answering one.

konekush said... The beta version is not allowing new reviews to load after answering one.
 I don't quite understand what you mean.  Could you open your developer console (F12) and see if it printed out any errors?  Also what browser are you using?
xMunch said...
konekush said... The beta version is not allowing new reviews to load after answering one.
 I don't quite understand what you mean.  Could you open your developer console (F12) and see if it printed out any errors?  Also what browser are you using?
Chrome Version 43.0.2357.130 m. I don't know how to reach the developer console (F12 just sends me to inspecting elements; is that what you meant?) , but the thing that hbappened is that I'd type an answer to a review, get it marked correct/incorrect, type enter to get to the next review, and nothing happened. When I disabled the script everything worked well, and when I installed the stable version it continued working well.

I won't have any new reviews for a few hours, but if you tell me what you're looking for, I'll see if I can recreate the bug in my lessons/quizzes.

ETA: I also use uBlock Origin v
ersion 0.9.9.2, but stopping it from blocking anything on the page didn't solve matters.
konekush said...Chrome Version 43.0.2357.130 m. I don't know how to reach the developer console (F12 just sends me to inspecting elements; is that what you meant?) , but the thing that hbappened is that I'd type an answer to a review, get it marked correct/incorrect, type enter to get to the next review, and nothing happened. When I disabled the script everything worked well, and when I installed the stable version it continued working well.

I won't have any new reviews for a few hours, but if you tell me what you're looking for, I'll see if I can recreate the bug in my lessons/quizzes.

ETA: I also use uBlock Origin v
ersion 0.9.9.2, but stopping it from blocking anything on the page didn't solve matters.
 When you press F12 there is a tab that says console.                 VVVV


If an error occurred it will be printed in the window below.  I'd like you to copy the last few items on the log.

The new BETA 2 thing doesn’t show up at all.


The longer I’m on the page, the longer the list gets.

App is down and out for me, too.  Not showing up at all.  

Hmmm…  Could you guys try pasting this into your console then refreshing.  If this doesnt work I’ll look at it when I get home.

$.jStorage.deleteKey(‘uids’)

If that fixes the problem I’ll do a hotfix later.

Is there any specific place this ought to be in?

konekush said... Is there any specific place this ought to be in?
 You paste in the area you can type in the dev console.  You scroll down to the bottom of the log.  You can paste that anywhere on WK so you don't have to be in reviews where it is spamming the console.
xMunch said... Hmmm...  Could you guys try pasting this into your console then refreshing.  If this doesnt work I'll look at it when I get home.

$.jStorage.deleteKey('uids')

If that fixes the problem I'll do a hotfix later.

This doesn't fix the issue, unfortunately. 
Tingyou said...
xMunch said... Hmmm...  Could you guys try pasting this into your console then refreshing.  If this doesnt work I'll look at it when I get home.

$.jStorage.deleteKey('uids')

If that fixes the problem I'll do a hotfix later.

This doesn't fix the issue, unfortunately. 
 I don't understand why this error is happening...  I just pushed an update, not sure if it will fix it, I may have oops'd.

https://gist.github.com/xMunch/6beafa1a79a77386cd92/raw/WKU.user.js

Haven’t yet looked at your update, but manually resetting uids to an empty array helped (  $.jStorage.set(‘uids’, []);   )

EDIT: Or it may have been a combination of clearing uids to an empty array and your update, not sure. I got your update midways trying to fix it myself, I think x)

EDIT2: With latest update (and a rebuilt uids), reordering does nothing for me - but the addon shows up on the screen.

Tingyou said... Haven't yet looked at your update, but manually resetting uids to an empty array helped (  $.jStorage.set('uids', []);   )

EDIT: Or it may have been a combination of clearing uids to an empty array and your update, not sure. I got your update midways trying to fix it myself, I think x)

EDIT2: With latest update (and a rebuilt uids), reordering does nothing for me - but the addon shows up on the screen.
 You have to click the scales on the sides to determine how you want it sorted.  The right one is level and type, if it is balanced out it will sort them randomly.  There is a bit of logic behind it, if you're doing levels and you have sort levels unchecked it will sort randomly, etc...

Stopped working in Firefox, but ok in Aviator.

So… Who wants to be the lucky individual(s) who help me find and fix this bug?

Is there anyway you can revert it back to the old, working, stable form of the application until you find the bug?  So at least we have an operational version of this bad ass application until the new and improved version is stable?