Wanikani Reorder Ultimate [old version, not working]


You’ll want to post the errors from while you’re still on the reviews or lessons page. I think the error you posted above is from while you were on the forums.

I’m still using my version, and it’s still working fine. Have you clicked on the scales on the left/right to select which sort priority you want?

On the lesson page, the interface may need to be expanded if it’s minimized. Look for a [+] along the right edge of the screen, and also try scrolling down in case it’s just farther down the screen. (That may sound obvious, but sometimes the layout just doesn’t make your brain suspect that there might be something further down!)

And again, check for errors while on that page.


Edit: reviews jsut started working… I’ll check back in later…


Well, now I feel quite silly, because after clicking on the right-side of the scales on Chrome in a Lessons session, everything sorted correctly. I had no idea I had to click on the scales; I thought I just had to sort the blue/pink/purple icons in the centre of the section (and maybe Force Reorder if reuqired). My apologies.


No worries… that’s actually probably the most common issue I’ve seen. It’s not immediately obvious what you have to do.


There’s still some sort of problem with Firefox/Lessons; the Web Developer / Web Console is empty when I’m on the the /lesson/session page, and Violentmonkey doesn’t show “Wanikani Reorder Ultimate 2 (irrelephant mod)” as one of the active scripts. But since Firefox/Reviews and Chrome is working OK, maybe it’s just an issue with my setup.


This has happened before, but I figure I should report it. No idea what causes it. Could be a conflict between scripts, since I have 32 of those active during reviews. No relevant errors in console (only the confetti script’s errors). All I know is that it happened when I submitted an answer. When it happened the answer I submitted did not take and I got the same item again.

Not much to go on, but it happens very seldom and doesn’t affect following reviews, so it’s not a big deal.


My mind is blown. What a lifesaver!


This was working fine just yesterday, but now it says
“WKU::Please Wait::Currently updating UID list… 100%”
and doesn’t load on the review page (it seems fine for lessons). I can’t think of anything I’ve done since then that could break it, and I tried disabling all other scripts and extensions just in case (using chrome, script v2.1.0). I don’t really mind about reordering, but the 1x1 mode is something I’d really like to have.

Console errors:

Uncaught TypeError: Cannot read property 'substr' of undefined
    at HTMLLIElement.eval (userscript.html?id=851db51c-63ba-4e66-b30e-7a4542c54fbc:163)
    at Function.each (application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:1)
    at pe.fn.init.each (application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:1)
    at HTMLElement.eval (userscript.html?id=851db51c-63ba-4e66-b30e-7a4542c54fbc:161)
    at Function.each (application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:1)
    at pe.fn.init.each (application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:1)
    at Object.eval [as success] (userscript.html?id=851db51c-63ba-4e66-b30e-7a4542c54fbc:159)
    at c (application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:2)
    at Object.fireWith [as resolveWith] (application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:2)
    at r (application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:3)



Oh sorry, I didn’t realise that was a different version >.<
It seems to be working again for the time being, thanks for your help :slight_smile:


TypeError: Cannot read property ‘rad’ of undefined
TypeError: Cannot read property ‘rad’ of undefined at Object.updateVisual (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=bed95bf1-4f0c-4c7a-94db-cc75d5727c02:43:12) at Object.apply (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=bed95bf1-4f0c-4c7a-94db-cc75d5727c02:132:13) at Object.create (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=bed95bf1-4f0c-4c7a-94db-cc75d5727c02:185:17) at Object.init (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=bed95bf1-4f0c-4c7a-94db-cc75d5727c02:104:14) at HTMLDivElement.eval (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=bed95bf1-4f0c-4c7a-94db-cc75d5727c02:637:8) at HTMLDivElement.dispatch (https://cdn.wanikani.com/assets/v03/review/application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:2:21597) at HTMLDivElement.g.handle (https://cdn.wanikani.com/assets/v03/review/application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:2:18292) at Object.trigger (https://cdn.wanikani.com/assets/v03/review/application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:2:20714) at HTMLDivElement. (https://cdn.wanikani.com/assets/v03/review/application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:2:28182) at Function.each (https://cdn.wanikani.com/assets/v03/review/application-6a52b1cb5b0df7ce73e4153ccc5ee8c77c7f0ea35cbc546584aa2ecea39cc06b.js:1:17256)

WKU Init()
Checking for UID updates
Applying UID levels


@rfindley I’ve been seeing some vocab on level 15/16 being listed as undefined in their levels. Does this need updates for database changes?


Undoubtedly so. I have a dirty hack ready that makes this use the Open Framework to stay up to date. I won’t know it if works until my next reviews come up on my test account, which will be in a few hours. I was testing level resets for the wkstats site, and that made all of my available reviews go away.


Maybe at some point I’ll build a script myself. I gave you my API key on wkstats to help out.


:point_right: [ v2.2.0 ] - Convert to APIv2 (via Open Framework)

This should automatically handle changes to Wanikani items now.


That fixed it for me. I have TamperMonkey set to update every 6 hours, but hasn’t been catching these updates. I had to do it manually.


That update seemed to have broken the script for me. The reorder box doesn’t appear at all anymore. I figure if I’m having problems, other people probably are, so I might as well bring it up

I’m using Violentmonkey, if that helps.

EDIT: I’m not very tech savvy so I don’t really know how to get console stuff like some other people posted. It’s a miracle i’m using userscripts at all.


To check the Javascript console, press F12 then click on the Console tab.
Also, do you have the Open Framework installed, and positioned as the first script to run? I think in ViolentMonkey, you can drag the Open Framework to the top of your scripts list to make it run first.

Edit: Also, which browser are you using?


I was using firefox.

Good news though, I fixed it. >_>

It was noscript that was causing it, predictably enough.


I’m having some issues also. Basically when I’m doing reviews, if i click my mouse somewhere, everything becomes unresponsive. I really mean everything, I can no longer click any buttons of the reorder script, I can’t click in the window to type answers, I cant click on my skip button, or override button, even jitai doesn’t show a “clean” font anymore when i hover over it.
I have taken way too long to figure out it was this script, since i turned off all scripts and enabled one by one (or at least a conflict, since everything works fine when i disable this).
I have Open Framework installed and dragged to first place (I did that a while ago, but reinstalled both that and the reorder script so had to do it again just now).
I’m using Chrome Version 67.0.3396.87.
Also I suppose you need to know what error it gives in console.
I’m not really sure what exactly I should link…

Those are everything i find in red:P I hope that helps (sorry for being a noob) ashamed

EDIT: I just downgraded to version 2.1.1 you linked a few posts back, and that seems to have fixed the problem.