Vocab sound cutting off?

Yup, I did that and it fixed everything, that one replaces both Lightning Mode and Override. Thanks!


For anyone else reading this, the link to install:

Wanikani Open Framework (required dependency) - Install link
Double-Check - Install link

1 Like

This bug is especially bad this morning. Almost all the vocab audio is failing to play. I hope they fix this soon.

Update: It failed a couple times before I started counting, but after I started counting this morning, it failed 5/70 times, which is still much higher than before.

1 Like

Sorry for the slow reply. No, I would only occasionally hear sound, probably about 1 in 10 times. The problem is continuing.

I use MacOS Catalina 10.15.5. My browser is Safari 13.1.1. I don’t use scripts.

We are planning to revert both audio fixes today. Still trying to figure out what the root issue is with it, but it appears it has been disrupting people’s audio and access to lessons.


Great! Thanks for being so responsive and helpful to us users!

The sound is working great today! Thanks again! :slight_smile:

1 Like

today I installed the confusion guesser script and the visual similar kanji script. Since then the audio does not play anymore. Neither during the reviews nor on the self study script. I have to enter each vocabulary individually and hit the audio button.
Anyone any idea why that is and what I can do about it?
Thought I’m gonna write first here before starting a new thread :slight_smile:

Have you tried uninstalling those scripts?

1 Like

not yet… I was hoping that maybe there is another solution… since I would really like to use them :sweat_smile:
but if nothing works I will do that

My ConfusionGuesser script is only executed on the review screen, so I don’t think it is possible that it interferes with the Self-Study Quiz script, which as far as I know executes on the dashboard. But I also wasn’t able to reproduce the problem when trying out the Niai Visually Similar Kanji script. Does it still happen for you, or has it fixed itself in the meantime?

So at the moment it works during reviews, and on the Item inspector.
During lessons and the quizzes it is still not working. Which is quite weird.
I didn’t do anything beside turning off my computer and turning it back on now…

That does sound like a bug, but just to be sure, also check in the WaniKani settings if Autoplay audio in lessons is active. And in the Self-Study Quiz if the speaker-icon in the top left is yellow. And also make sure that you haven’t muted the browser tab (right click on the tab and see if you can unmute).

The next steps could be to disable your userscript manager (Tampermonkey,…) and test if it changes anything in the lessons, or disable all scripts except for Open Framework and Self-Study Quiz and see if the problem in the quiz is fixed. And/or, after the problem occurs, open the console of your webbrowser (F12 or Ctrl+Shift+I and go to “Console”) and look for error messages (and maybe post a screenshot of it here).

thanks you very much… everything seems to work now :slight_smile: i did turn off the audio settings and turn them on again… seems to have done the trick :wink:

1 Like

I did experienced this now. After tampermonkey update. I can’t live without ‘Always show item info’ script so turning it of is not option until WK integrates this function. Is there any hope that voice thing will be fixed.
Or should I maybe try some other script manager?

1 Like

I also started experiencing this but with @rfindley’s Double Check Script. (Which I also use to always show info so you might be using the same one)

I noticed he made some changes due to audio playing twice but in that thread I didn’t see any comments on audio cutting off as soon as one presses enter to go to the next word… (Chrome 91, windows 10)

Thanks for reply! I pretty sure, that the name of the script what i’m using is what i wrote. But it doesn’t matter anyway. And sorry, but I didn’t understand what thread you are talking about. Anyways to be clear ‘audio cutting off as soon as one presses enter’ is exactly my problem. :smiley:

If that’s the only script you’re using then it sounds suspicious. It doesn’t seem to affect audio though (WaniKani Always Show Item Info - Source code) but it could indicate another problem which is caused by some shared concept.

I have many complicated scripts running for wanikani so not sure what about Double Check is causing problems. My debugging wasn’t successful either.

No its not the only one but I turned everything else off. And they should not have affected audio either - wk ultimate dashboard - that kind of stuff.
In this tread someone said that background music sort of fixed it, but it didn’t work in my case.