Userscripts not working on new laptop, missing grants


#1

I bought a new laptop a few days ago (Windows 8.1 unfortunately, and Windows 7 wont work due to missing drivers).
As i often do my reviews on my laptop i installed the user scripts i usually use, but none of them seemed to work. So i removed them all, copied the source of one (Wanikani Real Times)  and tried again, still not working.
I’m Using Firefox 34.0.5 and Greasemonkey 2.3

Some Google Fu said that i should check the Error Console and add a GM_log to check if the script is executed at all. There i saw these 2 errors: “GM_addStyle is not defined” and “GM_log is not defined”. Some more Google Fu lead me to the solution to add this line to the script

// @grant GM_addStyle

This solved the issue for this particular script. But what is causing all this? Why is it working on my old laptop and my desktop PC, but not on my new one? What do i have to do so i don’t have to change all the scripts? The old laptop is using the same Firefox and Greasemonkey version.