[Userscript]: WaniKani Ultimate Timeline


#645

Sorry, I ended up missing this before it worked its way off the screen.
Please let me know if you see it again.


#646

Weird, now it’s this bar that has the problem. Wonder if there is some sort of set time interval? (23-24 hours?)


#647

I’ll take a look. Thanks!


#648

:point_right: [ v7.0.9 ] - Fix caching of ‘slice’ radical SVG.
(caused missing Review Detail pop-up)


#649

so i’m just wondering what the ‘apprentice IV’ is…
how many apprentice levels are there before guru??? haha


#650

There are 4 apprentice levels and 2 guru levels. Just 1 of all the others.


#651

thanks!
cheers for all your scripts btw!!!


#652

is there an option somewhere to stop the “Loading Data…” popup to stop grabbing focus? whenever i open a new tab of the wk homepage to search for something, i get a few letters of characters in, but then the popup grabs focus away from the search box.


#653

The popup should only show up if it takes longer than 1 second to load data from the Wanikani server, which should usually only happen the first time it loads data, or if Wanikani fails to respond. Is this happening frequently??


#654

every time i open the homepage fresh, but not if i refresh an old one


#655

Ahh, it sounds like you are running Wanikani in a privacy mode, or your browser (or a plugin) is configured to clear data when you close the browser. So, it’s having to reload about 10MB of data every time.

Can you disable those settings for www.wanikani.com?


#656

im running in chrome’s standard mode, but i’ll have a dig through the settings to see if there’s that setting


#657

after digging through for a while, i cant find anything. the cookie permissions (for all sites) isn’t set to clear on close. i’ve tried disabling all other scripts i have running on wanikani (leaving just the framework, ultimate timeline and progress plus) and it still persists.
i did play around with it for a while though. contrary to what i had said before, it seems to need to be reloaded on refreshes as well, not just on new tabs. so i started watching the console as i reload the page. about three seconds after the last bar of the “Loading Data…” box completed, a ‘Cleaning out 12 old file(s) from “wkof.file_cache”’ would appear (i use the timeline and progress plus, for reference.). if i refreshed or loaded a new wk in a new tab before it cleared, the timeline and progress rings pop up without loading, not too surprisingly. im not sure if this is new information to you, but it might be helpful.


#658

Are you seeing the “cleaning out 12 old file(s)” every time? If so, maybe you’re not running the latest versions of Timeline and Framework?

Which browser and script manager (e.g. TamperMonkey) are you using?


#659

yeah, it’s consistently those 12 with both scripts running. using only the timeline drops it down to 10, but they’re consistent again and using only progress plus is consistently 11.
im using TamperMonkey
the framework is 1.0.31, the timeline is 7.0.9 and progress plus is 2.0.6
sorry for taking up so much time with this


#660

Would you be willing to do a screen-share so I can look at this interactively? I have a screen-share server I use for business.


#661

sure, lemme know what i’ll need to do :slight_smile:


#662

[link deleted]

Be sure to select “allow control” when asked.


#663

just to check, i don’t need to do anything to remove the sreenshare program now it’s over right?


#664

Correct. You can close it out, uninstall, etc. And delete the downloadable if you want.