[Userscript]: WaniKani Ultimate Timeline


#604

This looks increasingly like a problem with Firefox :thinking:

Could you try opening the Javascript console (press F12 and click the Console tab), and type the following command and press enter:

indexedDB.open('wkof.file_cache')

Then click to expand the resulting IDBOpenDBRequest, and check if the error says ‘null’ or something else:


#605

This is what I got


#606

Thanks for the error info!

I did find the following info associated with that error:

For IndexedDB to work you need history turned on.
Options > ‘FireFox will Remember history’
As far as I can see it’s not documented anywhere but this is the trigger…


#607

Ah! Okay thank you so much!

It’s back!!


#608

Awesome! I’ll copy this solution to the Installing Wanikani Open Framework thread.


#609

:point_right: [ v7.0.6 ] - Force tiny bars to be at least 1px tall


#610

Just a feature suggestion I thought of.

Is there any way that we could get a display counter for the number of items that are at Apprentice 4? I always seem to find myself counting them ahead of time so I can plan for the number of lessons I do after I guru them.


#611

Do you mean specifically Apprentice 4 of the current level? Or of any level?
And what about if you fail some of those reviews?

It almost sounds like you might want to try [SRS Grid Details]:

It will show you your current number of items at each SRS level.
If you use it, be sure to turn on the setting “Breakdown by sublevel”.


#612

I do have a script that gives me a level breakdown like that. I just meant something that would tell me how many Apprentice IV items I had in my current review queue, for any level.

Whether I miss some of them is irrelevant. :sunglasses:

I just figured, you’ve already got a tab in the review popup that gives a general breakdown by overall level, appr, guru, mast, etc. But for Apprentice it might be nice to have it be a bit more granular.


#613

@rfindley The ultimate timeline script is not happy about me being in vacation mode!


#614

@rfindley

I’ve upgraded to the new version of your script, and the count for my current column is consistently 2 above my actual review counts:

In this screen shot, my review count is 1, but I’m hovering over the first bar and it says 3.

This is pretty persistent for me. After doing some reviews, the review count is always two higher than it should be. If I hit the refresh arrows, it still stays that way.

Can I help you debug this?

(Safari, OSX)


#615

Now that I’m looking for it, I haven’t seen those two 主義 reviews come up in a long time, but their pages say ‘available now’.

This might actually be a @viet problem, and is a server side inconsistency.

https://www.wanikani.com/vocabulary/楽天主義 shows available now, but it’s not actually in my review queue, I haven’t seen it a very long time (across multiple devices/browsers, including ones that have no scripts)


#616

Make sure to update the Open Framework to the latest version. The new API still returns items that have been removed from WaniKani and @rfindley only recently updated the Open Framework to filter them out.


#617

@seanblue,

That was my first guess… and a good one.

In this case, though, those items are moved, not deleted. They moved from Level 21 to Level 23 on April 18th. And note that @chezmax is on Level 22.

I assumed that if they were unlocked already, the reviews would continue as normal, but that doesn’t appear to be the case.

Today, I’m putting together a tiny page on wkstats.com for people to submit their APIv2 keys to me for troubleshooting, so I don’t have to post my email address every time I need an API key. I’ll post the URL when it’s done.

Anyway, I suspect this may indeed be an issue for viet and oldbonsai. I won’t know for sure until I’ve seen if there’s anything in the API data that I can use to distinguish items like this.


#618

I thought that was the case too… Maybe this is a bug on their side, unless this is intentional for some reason.


#619

I was quite suprised because the timeline on my smartphone was updated and I could see some new options but the one on my computer didn’t. I tried to disable all other scripts (keeping only framework and this one) but saw no changes.
In the end I decided to reinstall the script. When I clicked on the link I only saw the option to install but not reinstall.
I now have to timeline haha. Don’t know why the old version 6.5.1 couldn’t be updated.



I will remove the old one but just wanted to give this information in case someone else have this issue.

By the way many thanks for this script which helps me a lot.


#620

Ahh, it’s because they’re named differently:

WaniKani Ultimate Timeline
Wanikani Ultimate Timeline
    ^

#621

I tried to see if the name was different but didn’t noticed this.
image


#622

Well, now that I’ve figured out the case, it’s only slightly annoying :wink:

At least it’ll clear up in a little while when I hit level 23, assuming I ever do my lessons. :slight_smile:


#624

This doesn’t look like our issue.

It is not the case

Criteria for review is (in pseudo’ish code) is user.current_level <= subject.level && assignment.available_at != null && assignment.available_at =< Time.now. It looks like the script is missing the level check?