[Userscript] WaniKani Show Specific SRS Level in Reviews

doesn’t work T_T

Sorry, I’m not sure what else I can suggest then. :worried:

okay- thanks anyway ^^

@Krispy
@seanblue

found the reason why. i tried it now several times and I am 100% sure.
the script works if i deactivate the reorder ultimate 2 script. but i need the reorder script lol.
@rfindley do you have a solution for that ?

2 Likes

Depending on what you use reorder for, you could always try Lesson Filter instead. But yeah, hopefully rfindley can fix the conflict in reorder.

my temporarily solution is now to use use a similiar srs level script.

i think you know this. just changed the srs level names to your appr.1,2 and so on. but i hope i can return to your script soon.

Sorry, no. It’s not really my script… I just patched it to get it to work with APIv2.

The CORS warning is interesting, though I don’t think it’s actually impacting anything.
It looks like the main error is that something is calling apply() on an object instead of a function. I’m not sure which script (or Wanikani code) is generating the error.

1 Like

hm however, only if I deactivate the reorder script everything else works well. the others scripts as well
could be that the source of this problem is something else, but the effect of this error is the situation i discribed.
i will follow up this topic. if if find out something new, i’ll let you know :slight_smile:

Version 1.0.1 fixes a conflict with Reorder Ultimate, so they should both work together now. Sorry it took so long @SerahShirin.

3 Likes

Cool! It worked now (on my second account, since I must wait for the next 5h to have reviews again on my main account.)

49

1 Like

Wow, this script just hit 1000 installs! :tada:

4 Likes

I’m always a bit taken aback that this is my most popular script since I made it on a whim in response to this random comment from Leebo.

4 Likes

You didn’t even like the post, haha. :slight_smile:

1 Like

I did respond to it though. :slight_smile:

Did you ever even use the script? I’m kind of curious.

Ah, I didn’t see that at the time.

I didn’t know about it before, but I will now, lol.

1 Like

Oh no. Guess I should have tagged you back then. :sweat_smile:

2 Likes

Sean,

Is this a bug or is this a feature? But this behaviour didn’t work as I expected.

This has been a while actually, but now I can tell you about this.

On review session, I failed to burn 取り決め item, so it went down to Guru 2. But before I hit enter, I added “persetujuan” as user synonyms (means: agreement in my native language), so before I ended my review session, I was asked again for 取り決め and I answered it, though, correctly this time for both reading and meaning.

Now, based on WK server side, the progress status for 取り決め item should be still “Guru 2” right? But your userscripts showed me Arrow Up + Burned. Shouldn’t it show me Guru 2?

1 Like

That is a bug, but not in my script. It’s a long-standing WaniKani bug.

2 Likes

So this bug only occurs when adding a synonym?

As far as I know, yes.

1 Like