[UserScript] WaniKani Lightning Mode

Hello - I’ve just re-downloaded all the scripts that I used to have. I’m one of those Mac users that updated the software and then found out TamperMonkey was no longer compatible (briefly)
Since I’ve now purchased TamperMonkey and added the scripts back in lightning mode only the

part of the script works. The second part…

doesn’t work for some reason. Has anyone else experienced a similar issue?

I would recommend you install Double-Check instead, as that script is newer and incorporates Lightning Mode


Okay thanks for letting me know! :smiling_face_with_three_hearts:

I decided to give a few scripts a try. I really like this one as I can zip right through the correct answers. I tend to open the review anyway when I get them wrong. Really helpful. Thanks.

1 Like

Lightning mode from today has continued to submit my answers when correct, but subsequently marks them as wrong so they come back to ask again! anyone else had this problem/ has a fix?

1 Like

I would suggest you switch to Double Check which has Lightning Mode incorporated and is better maintained

Sorry i do! When I turn off the lightning mode in Double check it’s fine. (Although I have to refresh to make it fine) but when lightning mode is on it doesn’t mark them as correct

So if I understand correctly, the problem is the Double Check script and not the Lightning Mode script (this one)? Then this is probably my fault. 2 days ago, @rfindley added a bugfix that I proposed for the Double Check script, but yesterday I realized that my bugfix introduced a new bug in case someone tries to submit an empty answer to a meaning question. I have already sent a bugfix for my bugfix, so it should get fixed soon.

However, I could not reproduce the problem you have described. Lightning Mode still works even with the bug. So if you come across this problem again, could you please check if an error appears in the console (F12) that looks like this:


If there is no error “reduce of empty array with no initial value”, then it’s a different bug.

1 Like

@Sinyaven, your fix is live now.

1 Like

Are you running both the [Lightning Mode] script and the [Double Check] script? If so, uninstall the [Lightning Mode] script and use the version built into [Double Check]. Even if you disable lightning in Double Check, Double Check is still incompatible with the standalone Lightning Mode script.

1 Like

No, I’m only running the double check. I’m afraid it’s still doing it in lightning mode, but I have actually realised it only submits the meaning as wrong, the readings are fine. Sorry @Sinyaven I do not know how to bring up that panel. My mac thinks that f12 is volume up and nothing (alt or ctrl or combination of the two) can make it think otherwise.

Actually did someone update it one minute before I posted that comment above? because it seems to be fixed for me now… and I can see in my tampermonkey it got updated 10m ago


I was discussing the issue of speedy reviews on this thread where Lightning Mode got brought up:


And it got me wondering if this “Lightning Mode” (or any other) Script has a timer. As in, you get say ~40 seconds to give an answer and if you don’t get it within that time-frame, WaniKani automatically marks it as wrong. I’ve searched the forums but didn’t see anything.

I don’t care much about leveling up fast but more so that It’s so easy for me to just get complacent and spend a minute or more on one review. I need something to keep me honest and improve my memory speed.

This is old, but it was working last I tried it (maybe two years ago :eyes:)


I’m encountering an problem and I was wondering if anyone else is having the same issue. If I have Lightning Mode on and it is now skipping the audio for vocabulary words instead of autoplaying it like it used to. If the script is disabled it plays the audio like normal (but if I hit enter it prematurely ends the audio, not sure if WaniKani used to do that since I’ve been using Lightning Mode for the longest time without issue). Any help would be appreciated. :slight_smile:

Yeah I’m having the same issue. Disabled it for now wonder if WaniKani changed something to break this.

1 Like

That’s what I figured since I hadn’t changed anything on my end. Thanks for confirming that the problem isn’t just something affecting me.

@goberflunk and @Tyogin You should both disable this script and try Double Check instead, which has a lightning mode feature incorporated. I don’t think that this script is being maintained anymore


Double Check solved the issue for me, thanks a bunch!


Thanks Kumirei, I just installed this and it still works two years later. The first and only script I have installed. I set the counter to 20 seconds which I feel is fair.

Time to strap in a feel the G’s. My accuracy will plummet but them’s the breaks.