[UserScript] WaniKani Lightning Mode

Try this:

:point_right: [v1.0.7] - Fixed issue with proceeding at end of lesson group.

1 Like

Thank you, this fixed the problem!

1 Like

Yooooooo I’m at lvl 5 now and i can’t even go 12 hours without getting like 70 reviews someone save meeeee!!!

@JayJay111 Yoooo, you’re in the wrong topic :slight_smile:

@rfindley Thanks a lot :smiley:

For me, it just broke. I don’t know if there was a wanikani update or something. I did not do anything with userscript the last four days.
Edit: next time looking for an update should be done before posting. There was an update. Cannot tell if fixed as I dont have anything to review now.

Yoooooo my bad bro lol

I’m sorry to say that it has not been fixed for me yet :\ I just did some new lessons and I still have the same problem.

@neicul, @MechFactions, @sirati97, @Liras

:point_right: [v1.0.9] - Fixed issue with proceeding at end of lesson group. (Uses ‘enter’ instead of ‘click’)

I had to suppress WK from submitting lesson results so I could test this a gazillion times without running out of lessons this time. Should be fixed properly now. I still don’t know what WK was doing, somehow reacting twice to the simulated click on the submit button. So I just replaced the click with a simulated ‘enter’ key, and it works fine.

3 Likes

Once again, thank you very much :wink:

Hi! I installed the script without changing anything, and for some reason it’s halting every time there is an item with multiple readings/meanings. Is this maybe related to the fact that I’m also using the Auto Commit script? Thanks for helping!

It looks like Auto Commit is intended to do the same thing as Lightning mode. Is there some reason for running both?

I guess I’d try turning off one of them to see if the problem goes away. Lightning mode does have a setting to halt on multiple readings, so if that setting was turned on somehow, that would certainly explain it. You could try clearing that setting:

Open your Javascript console (press F12 and click on the Console tab), then enter the following command, press enter, and refresh the page.

localStorage.wklightning_halt_multiple = 0

I tried disabling one and trying the other by itself but didn’t see any changes regarding the halting. I’m using Auto Commit because it can go straight to next question without me pressing ‘enter’ at all if I get the answer right. So, i just type the answer and I never have to press enter. But multiple readings is still an issue, and it slows things down.
From my understanding, Lightning mode still requires at least one ‘enter’, right?

Also, I’m a noob on Mac, is the Javascript console something like… uh… the terminal?

Yes, lightning requires one Enter. I see the difference now. But I guess I’m still wondering what Lightning does that Auto Commit doesn’t?

Javascript console is sort of like the terminal, but it’s built into your web browser. I’m more of a Mac noob than you (at least you have one). Apparently, you can get to the Javascript console in Safari as shown [here]. The directions for other browsers are in there, too.

I’m a noob with EVERYTHING technology hahaha, though I did have the common sense to use Chrome. Thanks for the link, it was pretty straightforward! I’m going to test out whether it worked or not on my next review.

I guess the main difference between the two scripts is that Auto Commit takes zero Enter if you get the right answer, and Lightning needs at least one. Lightning also has the halting options that Auto doesn’t have, not to mention that it has an active and helpful developer! :slight_smile:

Ideally, from my perspective, combining them into one would be ideal to get through reviews quickly!

Ok, so, this is what it looks like when there’s multiple readings, nothing seems different unfortunately :frowning: I’m not sure what I’m doing wrong.

Do you mean that it’s requiring one Enter, or two?

Also, what other scripts (besides Auto Commit) are you running?

It’s requiring one Enter, but it’s taking a long time before that press that Enter so it can go through.

This is the list of scripts currently running.

Ahh, okay. That’s the Mistake Delay script doing that. There’s a setting at the top to allow you to disable the delayed Enter.

2 Likes

I feel so silly now! Thank you for figuring it out! Would you mind clarifying for me where exactly at the top can I disable the delayed Enter for multiples? Sorry I’m really new at this script thing!

Sure. If you open the TamperMonkey Dashboard, then click on the Mistake Delay script, you’ll see the code. Near the top of the code, you’ll see a section like this:

    //==[ Settings ]=====================================================
    var settings = {

        // Amount of time to delay (in milliseconds).
        delay_period: 2000,

        // Delay when answer is slightly off (e.g. minor typo).
        delay_slightly_off: 1,

        // Delay when multiple answers are available.
        delay_multiple: 1
    };
    //===================================================================

Set the 'delay_multiple' to 0 instead of 1, then save the changes (cmd-s, or use the icon), close TamperMonkey and refresh the Wanikani page.

I’m assuming you still want the delay when “slightly off”, otherwise you could just turn off the Mistake Delay entirely.

1 Like