[UserScript] WaniKani Lightning Mode

I was discussing the issue of speedy reviews on this thread where Lightning Mode got brought up:


And it got me wondering if this “Lightning Mode” (or any other) Script has a timer. As in, you get say ~40 seconds to give an answer and if you don’t get it within that time-frame, WaniKani automatically marks it as wrong. I’ve searched the forums but didn’t see anything.

I don’t care much about leveling up fast but more so that It’s so easy for me to just get complacent and spend a minute or more on one review. I need something to keep me honest and improve my memory speed.

This is old, but it was working last I tried it (maybe two years ago :eyes:)


I’m encountering an problem and I was wondering if anyone else is having the same issue. If I have Lightning Mode on and it is now skipping the audio for vocabulary words instead of autoplaying it like it used to. If the script is disabled it plays the audio like normal (but if I hit enter it prematurely ends the audio, not sure if WaniKani used to do that since I’ve been using Lightning Mode for the longest time without issue). Any help would be appreciated. :slight_smile:

Yeah I’m having the same issue. Disabled it for now wonder if WaniKani changed something to break this.

1 Like

That’s what I figured since I hadn’t changed anything on my end. Thanks for confirming that the problem isn’t just something affecting me.

@goberflunk and @Tyogin You should both disable this script and try Double Check instead, which has a lightning mode feature incorporated. I don’t think that this script is being maintained anymore


Double Check solved the issue for me, thanks a bunch!


Thanks Kumirei, I just installed this and it still works two years later. The first and only script I have installed. I set the counter to 20 seconds which I feel is fair.

Time to strap in a feel the G’s. My accuracy will plummet but them’s the breaks.



When used during the lesson quiz, after getting a wrong answer that causes an info box to automatically open, this script will sometimes cause that box to immediately close again without user interaction. Any chance you could fix this behavior or make doublecheck work in lessons?

Edit: Upon additional investigation, it looks like the relevant lines are:

case 'warning':
case '':
	$('#additional-content #option-item-info').click();

So if there is no explicit case for incorrect, and this causes it to click the item info button. This means that when the answer is wrong, the item info box will be automatically opened if it was closed and automatically closed if it was opened. What is the expected behavior?

hey, I since I updated chrome the lightning mode script doesn’t seem to work anymore :confused:
hope you can help me out, thanks in advance

First recommendation would be to switch to Double Check script, which contains a newer (and still supported) version of lightning mode. You can disable the Double Check features that you don’t want to use.


just installed it and everything works just fine, thank you :relaxed:

edit: still have one question. enabled the "Show Item Info
" feature but the info won’t show when my answer is incorrect. the page will drop down a bit but the info won’t pop up


these are my enabled scripts btw

To get the info to display upon wrong answer when lightning mode is enabled, turn on “Delay when wrong” in the Mistake Delay tab.

I suppose I could make that more intuitive by automatically turning on “Delay when wrong” if “Show Item Info -> After incorrect answer” is enabled.

Then again, I wonder if that would create confusion for people who want lightning mode to auto-advance even during a wrong answer. In that case, “Delay when wrong” would have no effect. So, maybe it’s better to leave it as-is.

Anyway… as I said, just turn on “Delay when wrong”.

1 Like

thanks for replying

I actually have this option turned on. I guess something is hindering the info box to open when I get a wrong answer :thinking:


Hmm… okay.
Unfortunately, I won’t have time to look into it for at least a few weeks. But if I remember by then, I’ll take a look.

1 Like

I’m pretty sure it is because you still have the lightening mode script enabled. It is interfering with the double-check script.


thank you, guess I overlooked that.

everything’s working fine now :blush:


Is there a way to put the button basically anywhere that isn’t right next to the home button? Misclicks from that (especially with a slightly janky mouse) have caused me quite a lot of pain.

hey, I’m so sorry if this has been asked a bunch already, my brain is super tired lately, but is there a plugin that pairs well with this one where I can click something to show info on the previous item? or better yet automatically shows the info

You could remove this script and install [Double Check] instead. Double Check contains its own version of Lightning Mode, plus an option to automatically open the Info panel if you answer incorrectly (And also if you answer correctly, though probably only if you’re not using Lightning Mode).

1 Like