[Userscript] WaniKani Lesson Filter

Today it seems only the shuffle button is working for me, is anyone else having similar experiences?
Using the console, it is still possible to filter out radicals for me. I have tried both chrome and firefox.

Bug report:

I have 27 kana vocabulary lessons pending and 0 vocab lessons. When I filter for 10 vocabulary lessons I am being told that I can’t filter all lessons. But I thought the kana vocab lessons would be treated like ordinary vocabulary by the filter.

I have version 2.0.0 of the Lessons Filter script.
Tampermonkey on Chrome on Windows 10.

Yes I’m aware. I have this fixed locally but wanted to include a setting around kana vocab that I haven’t had time to get working. If I don’t have time within the next week I’ll probably abandon that for now and just release the bug fix.

4 Likes

Version 2.1.2 is now out, which will allow kana vocab lessons to be learned. I also fixed the lesson counts on the top right of the page.

I didn’t feel like making a full setting for the kana vocab, but if you really really really don’t want to learn them you can open the dev console and do localStorage.lessonFilter_skipKanaVocab = true. If/when WaniKani adds a proper user setting for this (hopefully sometime this century) I’ll replace this hidden version with full support for that setting. (If you change your mind and want to learn kana vocab you can do delete localStorage.lessonFilter_skipKanaVocab.)

5 Likes

works for me, thank you ^^

…and if i really want to do kana vocab, i just don’t filter…

hi, i downloaded the script and i have tamper monkey but whenever i enable the script no UI or anything showed up so i tried to follow the instructions with using the console and putting in the code text thingy but when i put it in the console says

VM7960:1 Uncaught TypeError: Cannot read properties of undefined (reading ‘filter’)
at :1:21

i need some help please
thanks.

Two questions:

  1. Did you install Open Framework and place it before Lesson Filter in Tampermonkey?
  2. What page are you viewing when you don’t see anything show up?
2 Likes

i do have open framework and i got it first and this is the page im seeing (i already have 1 script installed)


its just wanikani.com on google

The lesson filter shows up on the lessons page (the destination of the pink crabagator link), prior to the quiz. It looks like you don’t have any available lessons left today.

It’ll show up as the dark bar under the kanji tiles at the bottom of the lessons.

3 Likes

oh my bad, I thought it was just an open UI that was open whenever, my bad :disappointed_relieved:

thanks a lot though

2 Likes

How does the suffle command work? Does it show new items randomly selected or does it show the next batch in one’s learning queue?

It completely randomizes the lesson queue (after taking into account your current filter).

1 Like

Thanks a lot for your quick reply and for the script! Since the cherry-picker script is broken (as far as I know) I used your script to see my entire list of subjects (changed the batch size variable value) and then manually picked the ones I wanted to learn (fake example: https://www.wanikani.com/subjects/9226/lesson?queue=9226-9207). It is ugly but now I can avoid most of the kana only words.

There is a secret setting in this script to skip all kana vocab if you’d like.

2 Likes

Thanks! I added x-ray and deck of cards to my reviews. If they add stuff I never saw before I will add too even if I think kana only vocabulary is the worst idea that WK in the last 4 years.

dunno if this is the right place to post, noob forum user here! Im’ having a weird bug where the filter will only let me have 1 item per lesson, just trying to do my radicals first in the new level but it’s a major PITA doing them this way.
I’m getting multiple instances of this error in the console:
ChunkLoadError: Loading chunk 860 failed.
(error: https://js-agent.newrelic.com/860.03a8b7a5-1.236.0.min.js)
j https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
e https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
e https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
o https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
importAggregator https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
s https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
o https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
importAggregator https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
m https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
start https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
start https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7
https://www.wanikani.com/subjects/3025/lesson?queue=3025-3035-3036-3037-3047-3048:7

Any idea about the reason?

No idea about that error. Could be unrelated to the script. Can you post a screenshot of your filter settings (the colored inputs with whatever you typed into them)?

You are correct on that: it was related to tracker protection on Firefox. I deactivated that for WaniKani and those warnings went away. The problem of not loading more than one lesson at a time still persists tho.
Here’s a screenshot of the page, filter configuration, and console errors.

Ok, I figured it out.
Tl,dr: I was just too dumb to properly read the instructions. User error. :persevere:

The orange input bar needs to be equal to the total of the others or bigger. After re-reading the install post it was glaringly obvious. Brain fart on my side, sorry!

I’d actually recommend leaving the batch size (orange input) blank most of the time. Then it’ll just use the batch size from your WaniKani settings.

There actually is a slight bug (or bad design choice) here. I shouldn’t really let you set the batch size to 0 to begin with. I just pushed a small change to address this.

2 Likes