[Userscript] WaniKani Lesson Filter

In that case I have no idea what’s going on on my side. :open_mouth:
I’ll try out some things later to see what could be causing it but I can’t promise any findings.

1 Like

I’m having issues with this… but have found a work-around but figured I’d share in case it helps.
I really don’t know much about how scripts work but I’ll try to give all the info I can.

I’m using Firefox and have disabled all scripts but this.
The filter button works as usual but after going through the lessons and clicking ‘start the quiz’ I just get a white screen. Refreshing takes me back to the very start of the lessons.

However, clicking ‘need more time’ and then the green quiz button seems to work just fine.
Also, if I don’t filter I’m able to get to the quiz as normal.

I’d love give more info like errors and what-not but not 100% sure how to so please let me know how to do that!

Thanks!

2 Likes

I encountered the same white screen problem and your work-around fixed it for me. Not saying it’s going to work every time but it does this one time. Thanks a lot!

1 Like

I’m encountering a similar problem. Firefox on Mac OS. It’s worked perfectly until today. When I filter the lessons, the display at the bottom (showing the current batch) updates, but the item I’m actually focused on doesn’t. I can get to the proper first lesson by clicking it in the bottom display. Then things seem to work as normal until I get through the last item. Once there I’m blocked and just can’t continue. The quiz button is disabled and I don’t get the pop up asking if I’m ready or need more time. The console doesn’t show me any errors as far as I can tell.

I know they got rid of compatibility mode, but I thought this was working with compatibility mode off already. Does anyone know if they announced other changes to the lesson page?

1 Like

A while has passed and I have tried out some things – I’m still not sure what exactly is going on but I think that I could determine the culprits in my case.


To have a record of what I tried, I will explain my whole troubleshooting process:

I tried some basic things first, such as refreshing the lessons page several times, turning tapermonkey off and on and re-installing the lesson filter script. Only once did the filter script show when I refreshed the lessons page, only to be gone again after I went to the dashboard and then to the lessons page. I don’t know what triggered this. All other attempts in refreshing and altering between the dashboard and lessons page did not work; the filter was not there.

I then went to my tapermonkey settings and moved the lesson filter script up a few ranks. When I went to the lesson page right after, it showed again – only to disappear after I went back to the dashboard once and returned to lessons again. The filter didn’t appear anymore.

Next, I went to the app settings in Wanikani, actually turned off the script compatibility mode, immediately went to lessons – and the filter was there! But only for that session because after going to the dashboard and going back to lessons, the filter had disappeared again. Afterwards, I went back to the WK settings page and turned the script compatibility option on again.

The last thing I did was to turn some of my other scripts on and off. It seems that this is the main aspect that causes trouble: within my 7-script combination, two scripts seem to influence the lesson filter as of now.

Script combination experiments

If I turn off either the Niai Similar Kanji or the Pitch Info script AND refresh, the lesson filter appears and remains there. I made some more tests by toggling the other scripts and the filter shows with even 5-6 of my scripts enabled as long as either Niai Similar Kanji or Pitch Info is turned off. Weirdly enough, I can still keep one of them on despite both seemingly causing issues.

So there seems to be a collision there which I assume has only started to happen ever since the beginning of the script compatibility retirement process. My 7-script combo was working just fine all this time until 3(?) days ago.

This is all that I managed to find, I hope that my report is somewhat useful.

@seanblue I don’t remember reading about changes to the lessons page specifically either, so I can’t give you more info in this regard. :pensive:

3 Likes

I’m having a big issue with this script lately. After I filter a lesson and get to the end of the items, the popup to start the quiz doesn’t show up. If I don’t filter or only shuffle it the quiz pops up just fine. This has happened in Chrome and Edge and on two different computers. I tried running just the filter script, used tampermonkey and violentmonkey, and ran it with and without script compatibility turned on. It seems like the only constants are Wanikani and the filter script. Did something happen that’s causing the two to not work together anymore?

Something certainly seems to have happened since several people now have mentioned this issue. That said, I just tested it briefly (Chrome, Tampermonkey, compatibility mode off) and it seemed to work fine. I clicked Filter, hit Enter or Right Arrow a bunch of times, and then the Quiz popup appeared like normal. How are you progressing through the lessons to get to the quiz?

I’ve tried arrow/entering and skipping through. Neither way has worked on my computers. I’ll keep trying to get it to work, being able to study vocab along with kanji is too handy a function to lose.

Can you check the dev console for errors? Just hit F12 and select the Console tab prior to opening the lessons page. Then do the Filter and hitting next as usual and see if any errors appear.

I’m getting an Issue notification
“Audit usage of navigator.userAgent, navigator.appVersion, and navigator.platform”
and this error shows up sometimes
“VM113 content.js:58 Uncaught pagejs missing”

I think I found a workaround though. If I enter a number in バッチ that’s less than or equal to the number of items that would show up from the other three fields, the popup comes up at the end. If I leave it empty or enter a number that’s too big, nothing comes up. At least I can use that fix for now

1 Like