[Userscript] WaniKani Katakana Madness

First off, thanks for this great script!

I noticed today that hiragana was showing up for some onyomi in my kanji lessons today:

鳥 Lesson Bug

黒 Lesson Bug

風 Lesson Bug

There were about 10 others that I noticed from L7. Katakana is still showing up everywhere else for me it seems (reviews, level pages, item pages, etc…)

Not sure when this started happening…didn’t notice it during my last batch of kanji lessons on Sunday.

1 Like

Same here. I’ll add ノ, ウ and ワ to the list. And all those that you seldom get to use.
Thanks for the possibility to get some extra practice on those. :slight_smile:

This scrips scares me! :fearful: But, someone said “being brave isn’t about being fearless, but about facing your fears.” - or something to that effect.

I’m gonna install it and see how it goes! Wish me luck in the coming reviews! :sweat_smile:

First of all thanks for a nice script! Katakana is a definite weakness of mine and the repeated exposure to katakana on’yomi readings seems like just what I need.

I think there is a bug in your script, however.

If Katakana Madness is active when I start a new set of lessons, it works fine until I get to the quiz on the new items. What happens then is that when I submit the first quiz answer the lesson gets reloaded as if I were starting fresh. That is, the big Wanikani splash screen appears and I go back to the beginning of the lesson I am being quizzed on. This happens reliably and it doesn’t matter whether I am being quizzed on radicals, kanji or vocabulary. If I exit the lesson, turn off the script and retry, everything is fine.

I am using Chrome browser on Linux Mint and have a bunch of other scripts active by default – the dashboard cockpit, as well as WK Item Inspector and related scripts. I haven’t tried turning them off and running your script to see if there is a conflict there, since I didn’t want to overload myself with too many new lessons today!


I have the exact same problem, I also have a lot of other scripts, and am using Chrome on W10. I have fully disabled Katakana Madness as it just too annoying to have mess with my lessons, despite it being useful to train my katakana.

1 Like

I was (/am) also having this problem, so it was reassuring to see I’m not alone.

Looking at it, I think it’s because something changed in the way lesson results are submitted.

I don’t have a full solution, but a workaround is to add: https://www.wanikani.com/lesson/* to the “User excludes” in the TamperMonkey Dashboard > WaniKani Katakana Madness > Settings page:

That’ll keep that katakana madness in the reviews, but stop the lesson quiz from restarting.


It worked, thank you!

1 Like

Is there any way to do something similar with FlamingDurtles?

Go to “settings” → “other settings” and at the bottom of the page you’ll find the options “Show on’yomi readings in Katakana” and “Require on’yomi readings in Katakana” which you can toggle.

1 Like

How can I type dakuten properly? It keeps failing, potentially due to not being the proper dakuten character? It works fine without Katakana Madness.


Not sure what context is required, but hoping this helps: Brave, Tampermonkey, current version of Katakana Madness, on a MBP late 2013.

Thank you very much for this great script! Much appreciated!

im kinda confused what you are trying to do but just type “go” and it should work. You dont have to add the dakuten manually.

Uh - I’m just realising it myself. I’m using macos’ Hiragana keyboard layout, so that’s why the script can’t properly translate the key I guess.

You can just type with the normal English (or whatever you have as a default) keyboard, it will automatically convert to Hiragana for you.

Thanks, I’m aware. However, I want to practice typing as well as I don’t want to rely on an application feature. Other websites and programs do not automatically convert western keyboard layout typing into Kana.


1 Like

Great script. Definitely helps me quickly to sort out if WK lists 訓読み or 音読み reading for its Kanji. Thanks :+1:

You can convert your candidate into katakana with Control-K. Control-J converts back to hiragana.
Nevermind that doesn’t actually fix your problem. However Google’s Japanese IME let’s you swap the input method to katakana, which seems to work fine with this script. It uses Romanji input by default, since that’s how most natives type apparently, but can be changed to kana input.

Also, Google’s IME is having no problems getting dakuten onto the katakana even when I leave it set to Hiragana. :thinking: So that’s convenient.

Hi! I just started using this script and it seems to not be working with jukugo words. For 入力 it shows the hiragana にゅうりょく instead of katakana. Is there a way to fix this?

The script is only intended to effect kanji, not vocabulary.

I see. That’s unfortunate, but thank you for replying!