[Userscript] Wanikani Heatmap

Please update and see if this does anything for you

Heatmap v3.0.23.

I had to clear my chrome cache manually to solve it. in menu > parameters > erase navigation data > i ticked only the “picture and file on cache” box and erased, then relaunched chrome entirely and then it worked.

I think i also disabled/reenabled tampermonkey at some point too

2 Likes

I still encounter the issue

1 Like

Ok, so here are a couple of things you could try

  • Make sure your computer’s date and time is set correctly
  • Update your browser
  • Turn off any anti-virus
  • Clear cache
1 Like

Thanks!! I tried switching from the previous Wi-Fi network to my mobile data hotspot and now it worked!

1 Like

Glad to hear you got it sorted

1 Like

Pop-up card is a bit shy, hiding behind radicals and kanji:

image image

2 Likes

Should be fixed → Wanikani Heatmap

1 Like

Yay, no more shy cards! Thank you, Kumirei :grin:

1 Like

I’ve got a small aesthetic bug again. Like the last one, the heatmap is causing the page to grow wider due to a hidden popup. However this time it’s not the “toggle view” button, but the popup you get from hovering over the days. Since the dialog box is too wide to fit on the page, it’s causing the page to become wider than it should be again.

Figured that would eventually become an issue. I know what it is, will look into it

1 Like

Should be fixed now

2 Likes

The page now only resizes when the tooltips is visible, so that fixes it :grin:

2 Likes

Didn’t want to bother with checking whether it was going to overflow. Having them as display: none rather than just invisible is better for a number of reasons anyway

2 Likes

Agreed. Invisible popups are rendered by the browser even though they are not displayed. ‘display: none’ popups are not rendered. In Item Inspector I have found that rendering hundreds of invisible popups is a major source of latency when the script starts up. Using ‘display: none’ eliminates this latency.

1 Like

Yeah. Keeping the 0.5 second transition delay was a bit tricky to figure out, though, since you can’t transition at the same time as you change the display property

1 Like

How do you do it?

In Item Inspector I have the main divs within the pop up invisible and transition on them. When the display property is set to block I don’t go back to none and the visibility transition works on the inner divs.

1 Like

I listen for the mouseover event to add a transition class to the element for 20ms. The transition class updates the display property. Then I have a CSS rule :not(.transition):hover, which transitions the opacity with a 0.5 second delay.

1 Like

My heatmap…disappeared? Just me?
It’s enabled but doesn’t show up here.

1 Like

You changed your name! Luckily I have you tagged. Can you check the console (F12 → Console) for errors?

1 Like