[Userscript] Wanikani Heatmap


#101

Sorry, got caught up editing the OP that I didn’t update it on greasyfork. It’s live now.

Please tell me if the default to Sunday isn’t working as it should.


#102

It’s working! There’s a single pixel off at the top though:


#103

Doesn’t look like that for me. It’s probably a browser thing. Either way I can’t fix it. I have that on the right edge, but I couldn’t fix it.


#104

It’s definitely not a deal breaker! I’m so excited, thank you! \o/

ETA: look at this beauty!


#105

omg haha, that’s amazing


#106

Proper sakura colours!!

Pale:

Dark:


#107

Woo! This looks great! And double thanks for adding the gradient feature so I don’t even have to figure that out myself xD


#108

Could the switch between year order be optional? I’m not really fond of it. :sweat_smile:


#109

but… we had a consensus of 3%!!!

haha, sure. I’ll add it as an option


#110

Thank you so much! :relaxed: Sorry to bother you


#111

Updated with option


#112

Woah that’s quick! Thank you!


#113

Updating now! Waiting for the reload =^_^=
Thanks for the great update! =D


#114

I’m having a brain fart… Where do I find the settings? ^^;


#115

The settings are implemented via wkof, which puts the settings in the user menu.


Heat Map Stories! (WaniKani Activity Chart)
#116

Ah! Didn’t think to look there! =D
Thanks!
Oh, love the new features! <3

I made pretty colors too :wink:

57


#117

Awesome update, thank you! :slight_smile:


#118

My heatmap never look pretty since I’ve never done enough reviews for the two highest colors. @Kumirei Could we customize the ranges for the 5 colors as well?


#119

I finally got around to installing this, and it’s totally awesome :+1: . I like a good heat map, I do.

If it’s ok, I thought I’d mention a couple of things I found -

  • When I first installed it, the “lack-of-WKOF” popup only appeared for an instant before disappearing. Not a problem really, as I already knew to install WKOF, but still. I did try disabling all my other blockers and extensions etc, but it’s possible I missed something.
  • I think there’s something weird going on with my data for whatever reason. As I’m working through my humongous backlog, I’m doing reviews in blocks of 60-items at a time. I’ve done two sessions so far today (at 10am and 1pm approx), but right now the heat map only reports 60 reviews for today. But before I started my second session it was reporting 200+ items for today so I’m not sure what’s going on there. I’ll see how it looks later on today after sessions #3 & #4. :slight_smile:

Before the second session - 200+ items for today:

After the second session - now only 60 items for today, plus another day was added to the streak-stats:


#120

I´m having the same issue. I installed the script today and checked after every review, and it seems it’s counting only the last session of the day, not the total sum.
For the previous days it seems to be accurate, its a very cool script, very helpful for motivation!