[UserScript] WaniKani Fast Abridged Wrong/Multiple Answer


#22

That’s a feature. You can turn it off or only show it for items with multiple meanings in the settings when you click on the menu in the top right.


#23

Oh thanks for pointing that out, I didn’t even see that the original post has been edited… :woman_facepalming:t2: My bad.


#24

Whoopsie, coding bug on my part. Setting was being ignored. Fixed in v0.5


#26

I’m new to using scripts, so I’m sorry if this is an obvious answer. But how do I get my scripts to show up in the Menu? I’m not seeing it. Thanks!


#27

(This is tampermonkey on chrome)

There’s a menu in your extensions to see your scripts.


#28

Would it be possible to add an option not to show on wrong answers?
That may seem to be going against the spirit of the script, but when I get something wrong I like to try and figure it out before checking, whereas I would like to see the extra meanings / readings when I get it right (if there’s already another script that does that please let me know :slightly_smiling_face:).


#29

any chance it could be updated to work during the revision at the end of lessons as well?


#30

(Not that serious problem)

Is there any reason to fix the width or other sizes like font? If you resize (for example by showing the developer tools) the bar gets too short. Probably this should work without doing anything?

Screenshot

Conversely, for small screens it is only things that stays big. It’s probably best to use one of the existing styles that have the @media feature.

Screenshot


#31

I noticed that you added !important to the inline background style, is this really necessary? I had a userstyle matching the element to the background of the input box, but now I can’t override it anymore, since you don’t get more specific than inline !important.


#32

Unfortunately I had to add that when I changed from label to input. Made it input so it would inherit the styling of the actual answer field (related to @acm2010 request).
I’ll play with it more when I get some time.
@Kumirei Custom colors is now a setting. Will be red/green, unless you specify otherwise.


#33

One trick you can use to avoid using !important is to add your script name as a class to the <body>, then just prefix any existing CSS rules that you want to override with your script’s classname.

For example,
$(‘body’).addClass(‘wkfastabridge’);

Original css:
#answer-form input {…}

Overridden css:
.wkfastabridge #answer-form input {…}


#34

Not a bad idea.
I’ve put class names directly on items before to try and override without using !important, but results have been hit or miss. CSS can be a nightmare sometimes.


#35

yay!


#36

For kanji reviews, is there a way to display the other reading type as well?

In other words, if the requested reading is kunyomi, show the onyomi readings, and vice versa?


#37

I can’t find the options, my main page menu dropdown hasn’t changed at all… is there any way i can make it work? I"m on firefox, tampermonkey, and the script seems to be running fine otherwise.

all i want to do is have all the answers pop up even if i get it right, thanks!


#38


Nothing there? Any other scripts installed? Not sure why the main portion of the script would work but not the menu, unless some other script is interfering. :thinking:


#39

I have the wanikani override script running, but yeah, my menu is the same as always…
thanks for taking the time to help!!

EDIT: And now for some reason it works fine!! I have no idea why…


#40

Edit 2 [SOLVED]: I removed the script, reinstalled from the tampermonkey link, signed out of WaniKani and opened a new session of Chrome and it for some reason…that worked. Thanks to @MissMisc for the tips.

I am having the same issue unfortunately. I even disabled all other scripts on the page except for yours, but I am not getting the ‘Fast Wrong Answer’ showing up in the Menu dropdown.

Edit: Adding screenshot, if that helps for the console when running the script.


#41

Well with this script, there’s no need to automatically display the info after hitting enter but I can’t find what’s doing that. Anyone know what’s causing Item Info to open up on its own?


#42

If you’re on Chrome and are using the Wanikani Companion extension then that one does it