[Userscript] Self-Study Quiz

yes i did install the framework


I don’t see Additional Filters, or at least it is not in second position.

i replied before i see your reply xD. Yes i don’t have the additional filter, could you tell me where to get that?

I posted a link there.

And it still not there xD

You are looking at the wrong place.

First start Self Study Quiz.


Then you go into the settings of Self Study by clicking on the gear icon in the upper right corner.


Then you go to the Items tab. While you are there create a new preset using the new button. It is not a good idea to mess with the existing presets.


Then scroll down the list of filters and you will find it. It is greyed because by default it is disabled. Clicked on the checkbox to enable it.


yeah, the problem is the additional “scripts” is not there for me

This is odd because I see your scripts in your tampermonkey. Are they enabled?

There is a Tampermonkey icon on the upper right corner of your browser. Click on it.


The top row the checkbox must be at “enabled”. If not click to enable it.

Then in the list of your scripts the sliders must be at the green position. If not click on them to make them green.

Once this is done refresh your browser. Your changes won’t take effect until you do. Then check if this solves your problem.

i only need 3 scripts ( WK Open Framework, WK Open Framework Additional Filters and WK Self-Study Quiz) for this to work right? i already enabled the script from start so i really don’t know what’s happening here

Yes these scripts are sufficient. Something odd is happening and I am trying to find out what it is.

Did you check the Tampermonkey as I asked? We need to know if there is something wrong with your Tampermonkey. If everything is ok there are other things to check afterwards but there is an order to follow when troubleshooting these things. I need to be sure the Tampermonkey is OK before I proceed to the next step.

Open your Javascript console (press F12 and click on the Console tab) and post any errors you see there.

i think the Tampermonkey is ok, because i used some scripts for other sites as well and it works normally

Then press F12 and post the errors on the console tab as @rfindley suggested.

Here’s what they say, and i don’t understand a single bit xD

As I suspected. Security settings are blocking some scripts from loading, and indexeddb is disabled.
Is this Firefox? Or a different ‘secure’ browser?


Open framework complains that index.db could not open. @rfindley is the expert on this. i will let them the lead on this.

yeah i use firefox

I don’t use Firefox, so I’m only vaguely familiar with the settings. But I’ve noticed that people who have this same problem are usually somewhat familiar with the security settings. More so than I am, anyway.

OK, i don’t know what the frick is wrong with Firefox, but it works for Chrome, thank you all


posting just to say i love this script! thx very much!