[Userscript] Dashboard Progress Plus

Yeah, that’s the issue. Means get_items() is returning nothing, no?

Oh… that’s the debugger showing you the value? Got it. I thought maybe it was present in the script itself.

Hmm…

Try this on the console:

var items; wkof.ItemData.get_items({
            wk_items:{
                options:{
                    assignments:true,
                    review_statistics:true
                },
                filters:{
                    level:'+0',
                    item_type:'radical,kanji',
                }
            }
        })
        .then(data => items = data);

Then (after running that):

items.length

And see if it’s returning zero.

yep, getting zero. :confused:

Hmm. Try clearing just the APIv2 cache (in the Javascript Console):

wkof.file_cache.delete(/^Apiv2/)

Then reload and see if it works.

If not, could you try removing each filter, one at a time, from the test query I had you run above?

No luck with clearing cache.

removing level:’+0’ = 2529 items returned.
In fact, any number in level parameter = zero items. Even tried comma separated 1 to 41

Hmm… I don’t understand. Have you installed any other scripts recently, or had any script updates? I still can’t replicate this. Could you try temporarily disabling other scripts (except this one and Open Framework, of course).

Well, I think its safe to say its something screwy with my computer. Works fine on wife’s laptop, which should have the same setup as my desktop. Even just this and open framework being the only things active, same result. Even tried disabling bunch of Chrome extensions to no luck.

We can just blame @Kumirei. Noticed the issue after turning heatmap on, and then getting sick of waiting, and turning it back off. Granted, no idea if the issue was there prior, wasn’t paying attention. But, scapegoats eh? :wink:

1 Like

Interesting. Maybe a cached version of one of the Open Framework modules is goofy.
You could try clearing the whole wkof cache (which includes javascript modules), though you’ll lose any saved script settings:

wkof.file_cache.clear()

:sweat_smile: I think you might just be the person with the most reviews logged, so I imagine it must take a long time to load all of them

Only 796,725 total reviews… That’s nothin’ :woozy_face:
I wonder what my prize will be when I become the first million review durtle…

2 Likes

Gosh, I think it takes long with a mere 84,000 reviews

So, I just ignored the problem for a while and, its working again, for no apparent reason. :man_shrugging: Them darn technologies.

3 Likes

Not on topic, but could I possibly borrow a read-only V2 key from you? I’m trying to figure out whether it’s possible to cache reviews in localStorage by making it super minimal, and you would be the perfect test case. I think it’s theoretically possible

Sure, knock yourself out. Try not to laugh too hard at my stats.
ee2e0cd9-f0f2-4a8e-b5ac-9d6dffcce744

Thanks! I’ll be to busy cursing at localStorage being so small to laugh

1 Like

Honestly your stats are very impressive.

Reviews:
Days Studied: 92% (835 of 912)
Average Daily: 200 (219 per day studied)
Longest Streak: 243 (current 186)
Total: 182,669


edit: oops, was supposed to be reply to @DaisukeJigen

3 Likes

I know you meant the rest of the stats found at a certain stats website:

Disclaimer: I used the v2 key posted to obtain this image.

Quite honestly, even if they aren’t reaching 60 in just over a year, they’re not terrible or laugh-at-worthy. The fact that you have come so far in Japanese is impressive. Keep it up!

My dashboard doesn’t fit because of that horrible review forcast. I got rid of it somehow, but then there were changes made and it came back. Is there a line or two of code that will fix this? I can’t see all the kanji on the levels.

You can see all the kanjis. They wrap on the other line.