(Problem fixed) Ultimate timeline stopped working for me when it updated today

I am not sure what happened as it was working 3 hours ago, I noticed it said ultimate timeline updated 2 hours ago and it just won’t reappear on the wanikani dashboard for me ;-;

It is definitely enabled along with user scripts and tampermoneky itself, yes I did restart the browser, yes everything else is up to date, I am using Chrome on Windows 10, and I have another two scripts running that still work on that same page! Also I have removed and re-installed it but it is still not reappearing ;-;

Can anybody help me please, I tried to send a bug report but I couldn’t because I didn’t get what greasyfork was on about ;-;

1 Like

Mine says updated 46 minutes ago, and is still working.
WaniKani Open Framework is the first script listed in TamperMonkey correct?
Doesn’t appear at all, or appears broken in some fashion?

Can you hit F12 to pull up the dev console, and toggle to the ‘console’ tab, and refresh the dashboard? Do any errors shows?

Yep, I made an update, but all it did was add a settings link to the WK menu. When I tested, it worked fine :frowning:

I’m actually having the same issue. Ultimate Timeline completely disappeared at some point in the last few hours (it was working fine earlier today). Tried in both Chrome and Firefox, ensured Open Framework was installed and running first. Tried turning off my other scripts and refreshing and all, still nothing. I’m not getting any errors in the dev console.

Edit: I also don’t have anything for scripts in my menu dropdown from the dashboard, if that makes a difference? I don’t know that I’ve ever seen it, but it’s at least not there now. (Bladepoint mentioned it when I was talking to him about this and figured I’d include it just in case.)

Edit Edit: Followed the menu thing down the rabbit hole a little, went into the script to remove Menu from the wkof.ready(‘document,Itemdata,Menu,Settings’)… line (line 39 in my tampermonkey) and disable the startup function to install menu link (line 144 for me). Ultimate Timeline is now appearing on my dashboard again and seems to be working fine. So, not sure why it stopped working because of the update, but that’s what made it disappear for me.

1 Like

Just want to chip in to say I’m having the same problem. Was working earlier in the day, but then stopped showing up. Open Framework is first script in ordering, Firefox 65.0, other scripts are still working, have restarted the browser, did a hard refresh, saw there was an update not long ago, so thought that might have been it.

The only error I’m getting in the console is:
Script error: ReferenceError: "$ is not defined"
for Wanikani Pitch Info, so I’m guessing unrelated.

Edit: Tried @katvonbirb’s solution (removed Menu on line 39, and commented out line 144) and that solved the issue.

It stopped working for me after the newest update, too. I took the lazy route and just downgraded to the previous version to get it to work again.

Alternative (and probably more correct) fix - the Menu module is not included on line 38, just change it to wkof.include('ItemData, Menu, Settings'); and everything will work fine.

1 Like

Well, that’s a big “doh” and “duh”!
And explains why it worked for me… because I have other scripts that include “Menu”. I’ll fix this within the next hour or so.

Thanks for the troubleshooting!


Thank you to everyone who helped/ fixed it works for me again now too! Wow I am so glad to have it back :smiley: