[Outdated] [Userscript] Burn Reviews (ver 2.2.5)

Thanks for looking in to this in my negligence!
I saw you forked the project on GitHub so if you want to fix the script up and put in a pull request I’d be happy to merge it in :slight_smile:

I put in a pull request for that exact change right after posting :wink:

What might be the cause of this? It has always been stuck on “Retrieving radical data”. Have tried uninstalling and reinstalling the script.

I would rather recommend you look into getting the Self-Study Quiz script, which does include a filter for only burned items

2 Likes

Hello all, I’ve just pushed a really really horrible hacky fix to this script that so far as I can tell gets it to run again. You should be able to get the update from greasyfork. It still uses the old version1 api key which is set to be deprecated so without work to fix this, this script will not work in future.

Honestly I’d love it if someone took the maintenance of this userscript off my hands as I don’t really have capacity for it anymore. Really the whole codebase needs an overhaul using something like the wanikani open framework and all the new features that have been added to browsers and userscripts in the past 3 years since I decided to fix up this script.

If I re-find my motivation to study japanese, I might pick up maintenance of this again, but don’t hold your breath.

2 Likes

Looking up, I see this was already mentioned, but does anyone have any idea how to avoid the Burn Reviews script pushing the screen upwards and hiding some of it? After some testing, it seems to me that it doesn’t matter what other things are on the screen-- I’ve tried removal scripts for dashboard elements, scripts that add a full screen’s worth of boxes to the dashboard, and every time, the burn script seems to be what pushes the screen up for me.

I’d imagine this is just some kind of layout issue, possibly relating to the size increase button, but if anyone knows what might be going on and how I might fix it (through a fork or though coding it myself), I’d appreciate it. This is a great script, and I’d like to make it a permanent part of my dashboard.

I don’t use this script, but I toggled it on and did a review, and I don’t see any of this behavior. What exactly is happening?

Same issue as this, except I generalized it and it seems to be only dependent on the burn review script and not some conflict with other scripts.

Ah, I see. Had a look at it and it stems from the script getting the review page style sheet on line 177

You can either remove this and suffer the consequences (I didn’t check but I assume things look different without it), or you could just patch the issue by adding a CSS rule

#search {
    margin-top: 70px;
}

Thank you! Where do you add that, at the bottom of the script?

I think you should be able to add it after line 208, like this

2 Likes

That worked, thank you!

1 Like

The automatic “resurrect” button does not seem to work.

1 Like

I appear to keep getting this 404 page not found error when I try resurrecting an item. Screenshot - 85bf10ad7aa4a15b86aab8bef2df6249 - Gyazo

Hey there,
thank you for taking over maintenance as this sounds like an awesome script. Unfortunately it doesn’t seem to be working at all for me as I’m only getting a grey box with the title “Burn Reviews” and “New Items” at the bottom and the main displaying only “Retrieving Radical Data…”.
Tampermonkey is active and Open Framework is installed.
Might that be related to the problems with the resurrect button and the API Update to Version 2/new item IDs you mentioned in your first post or would it be a problem with my browser (then I’ll of course try to fix it on my own)?

EDIT: just scrolled up and saw this problem already mentioned and your answer. So just forget about my post. ^^’ Unfortunate to hear it won’t work with the new API but well…

Have you tried Self Study Quiz?

No not yet. I’m still working through the list of alle the available userscripts. ^^ But I’ll have a look at that.

1 Like

Hello, is this still being maintained?
The script is not working for me on Firefox with Greasemonkey.

Stack trace:

Looks like this broke with the removal of the old WaniKani API. Very sad.

There are two alternative to burn reviews. You may find them descripted in the top post for the Item Inspector script. Look for these “hide details” tag:

burned

The top post of Item Inspector is here: