(Obsolete) [UserScript] WaniKani Double Check

Correct. It does not play well with mistake delay. But, if this script negates the need for it anyways…

Did notice one thing though. It now seems to take a blank answer as incorrect (hit enter before inputting an answer). Unless that’s an underlying WK change…

I’ll take a look at this ^^^

Also, if there are any missing features of Mistake Delay that you’d like to see included here, let me know. Some of the code in this script actually comes from my version of Mistake Delay

I had a review for a reading, was slightly off giving me “Close But No Cigar” since I have that script enabled. I tried again to spell it correctly and then it immediately went to the next question (no idea if I spelled it right or not) and then saw “WaniKani is looking for the undefined reading”.

Looks to do the exact thing the other Mistake Delay did, so no worries. Although it does seem to do more. Puts a delay when you ‘get it right’ by being very slightly off (spelling errors). Not a fan of a delay there, but its my own fault for sucking as this spelling thing.

There’s an setting for that at the top of the script.

1 Like

rfindley, a sincere thank you. This is a huge, important script for me.

Thank you! A couple of notes/requests though:

  1. Could you make the retry option discussed an actual button? I’m on mobile, and can’t do hotkeys.
  2. I have the auto-play option enabled, and whenever I get a vocab reading right, the sound plays once upon getting it right, and once upon moving to the next item. Is there anyway to fix that?
  3. I’m not sure if there’s anything to do about this part, but the script makes reviewing a bit jerky and not smooth, even when not using the conversion option.

^^^

  1. Will do.
  2. I’ll see if I can find a solution to this one.
  3. Can you describe this in more detail? Also, which step is jerky: the first time you press enter, or the second?
  1. Seems to be only happening on mobile; it’s smooth on pc. The jerkiness happens right after submitting my answer (first enter/submit click).

Couple more things:

  1. When there’s a wait/delay enforced (wrong answer), but you click submit/enter twice in a row, you can’t open the item info panel either by hotkey or by clicking on the more info button.
  2. The SRS change indication (ie, the new SRS category an item is in after answering) doesn’t show up - it only shows up after answering the last item (this was also a problem in the original script, but isn’t a problem in the override script)
1 Like

I’m glad to see you are on the ball here. My life got busy. I went to Japan for my brother’s wedding and met a beautiful English girl. I’ve been so busy with things that aren’t wanikani and can’t maintain my scripts :’(

Heh… I’d choose the girl, too :wink:

I understand. I’m going to have to stop maintaining my scripts soon. I’m doing an overhaul on my scripts for APIv2, and then probably won’t do much past that.

:point_right: [v2.0.1] - Added ‘retype’ button. Changed hotkeys. Fixed delay/item_info bug. Added SRS notices. :point_left:

New feature:

Press <escape> or click ‘retype’ button to retype your answer. (ONLY USE FOR TYPOS!!)

Changed Hotkeys:

Press + to mark as correct.
Press - to mark as incorrect.
Press <escape> to retype answer.

“Mistake Delay” changes:

You can optionally prevent double-taps on the <enter> key to prevent skipping past important info and potential mistakes. There are three configurable options:

  • When you answered wrong (default: enabled)
  • When your answer is slightly off… e.g. a typo (default: disabled) <-- was previously enabled!
  • When an item has multiple meanings (default: disable)

Fixed:

  • Pronunciation audio will no longer play twice (unless you change your answer multiple times)
  • SRS level-ups / level-downs are now displayed normally (i.e. when meaning and reading are both answered).
1 Like

It appears to be broken. The previous script that you gave us stopped working, so I updated, and this is not working either. If I click the buttons, nothing happens.Is this working for anyone else? I’m going on vacation mode because I don’t want to get something wrong and lose six months of progress for not typing something right.

:point_right: [v2.0.2] - Fixed buttons :point_left:

@rfindley
The script seems to break the SRS indicator settings (hidden or shown during review).
I have turned them off, but they are still showing up.

Tested it with only this script active (version 2.0.2)

You probably just need to check if the class is present, the node seems to only get inserted when the setting is on, and not just hidden.

It works now! Thank you!

Ahh, yeah, I noticed the setting is in jStorage automatically. I’ll connect the setting tonight.

1 Like

:point_right: [v2.0.4] - Make SRS popup follow user settings.

(For those that are interested: [ diff ])

[Side note: I’ve noticed that clicking ‘Install’ on a specific version of a script on greasyfork.org causes TamperMonkey (and maybe other script hosts?) to NOT update the script when new versions are released. So, starting with this update, I’m always going to link to the main page of my scripts instead of the specific version.]

3 Likes

Works now, thanks.

I also noticed Tampermonkey not updating scripts automatically, despite the script update setting being set to update each day.

The fix for that, by the way, is to remove the “?version=xxxxx…” from the update url on the script editor page in Tampermonkey. Tampermonkey populates that URL when you install a script for the first time. I haven’t tested if it gets fixed automatically by clicking ‘install’ from the script’s main page.