Loading Data... Wanikani user

I have only three scripts : Wanikani Open Framework, Jitai, and a leech script.
Since the Wanikani layout has changed, my leech script doesn’t work anymore. A pop-up appears writing : Loading Data… Wanikani user. I tried many leech scripts but it does the same thing with all of them.

Would you know a solution ?

Thanks !

Sounds like a background error is occurring during the load - probably pops up somewhere during the framework processing (if all scripts display the same behaviour). Can you hit F12 and check for an error message in the console? That would help narrow it down.

Here are the errors I get with F12 :

Have you tried just refreshing?

Yes, the pop up reappears each time

Have you tried disabling adblockers and similar extensions?

1 Like

I just tried disabling all extensions (except TamperMonkey obviously) and the popup still appears

1 Like

251446983644938240 @rfindley you know what causes this?

1 Like

I would guess it’s a corrupted cache or indexeddb, or maybe when a user changes their apiv2 key. I’ve seen something similar at least once, and clearing cache (and/or indexeddb) solved it.

I would also recommend looking at the Network tab in devtools, because it will show what happened to the API query for user info.

Chrome cache cleared. Still popup.
I never changed any api key.

However, I don’t know what indexeddb is, nor how to clear it.
Don’t know neither how to look in the network tab in devtools.
If you tell me how to, I could try all of this.

Next thing I would try is to explicitly log out of WK and log back in. There might be expired credentials in the background or something? I would expect a cache clear to already take care of this though (did you have to log back in to WK after the cache clear?)

I already have to log back after the cache clear.
I did it again but it doesn’t solve the problem :confused:

I don’t know at all if it could help, but I have already tried to restart Chrome, and also the computer.