LipSurf - WaniKani Voice Dictation. Review while you eat, do chores, etc


#61

Doing reviews with LipSurf and lightning mode for the first time, it’s mostly working pretty well :+1:

A couple problems I’ve encountered:

  1. Spelling things out in English doesn’t work very well. I tried to spell out 届ける and it just didn’t get the last few letters at all. It would be nice to have a spelling mode.
  2. I said 「はれ」for 晴, which WK would normally mark as wrong, because of the extra letter. However LipSurf scanned はれ and found は, which is the correct answer, so it marked it as correct.

#62

What exactly was the issue? You said t-o-d-o-k-e-r-u and how did it recognize it as? For longer Japanese words the recognizer should be better. Sometimes you really need to empasize the “u” sound in “る”.


#63

To be clear, I switched to English mode and spelled it out. It got t-o-d-o correct, then k was recognized as “kay”, e was recognized correctly, then r-u was recognized as “are you”.


#64

Thanks for the clarification. Yeah, those are pretty much exact homophones (k-kay, r-are, and u-you). I will add them as global defaults (already have a bunch of new ones for the next version lined up).

I tried spelling it out myself and usually would get the same results as you did.


#65

I tried to use LipSurf last night and just now, and I couldn’t get it to respond to anything - it wasn’t even showing any live text. I tried turning the extension off and on, closing extra browser tabs, closing the browser and opening a new window, checked the extension settings. I looked in my Chromebook settings too, for a place to change microphone settings, but couldn’t find anything except for giving websites and extensions permission to use it (LipSurf already has).
Do you have any ideas that might help?


#66

I’ve run into two particularly annoying cases. There’s several where it can’t seem to identify, such as anything read き, where it tries to guess one of several possible kanji instead of the kana. I kind of expect it though, and I’m sure I’m not the only one who’s said that.

The more specific case is that it absolutely will not pick up 名字. It should be guessing kana anyway, but instead it continuously spits out 苗字 in kanji form. I’ve had to use the correct override every single time… It’s not that big of a deal, thanks to the override especially, but I wonder why it won’t recognise?


#67

I will make a FAQ for this on the website soon. There’s a few things to check.
Seems you already checked 1) that you’re connected to the internet 2) LipSurf has permission and 3) LipSurf is activated (the red dot in the icon is there when it is)

  1. Is your microphone muted or does chrome have an issue with it? You can check here: https://www.onlinemictest.com/
    I always do this and it takes me a minute to figure out :sweat_smile:
  2. Are you on a non-special tab? Test the mic while your active tab is a normal website like google.com (or wanikani.com) … LipSurf won’t work on chrome://... tabs and the “new tab” tab – this is a chrome limitation.

If you’ve verified those and it’s still messed up, there’s still these hard-reboot options. But please make sure you actually need it as it will reset all of your settings and force you to re-download the lang pack.

  • “Factory Reset” button in the options

#68

Thank you for posting this! This verifies something that I suspected and ran into before personally. Two things:

Here’s how it works. The google speech recognizer gives LipSurf transcripts with kanji, and LipSurf will segment those, find kanji words in a big dictionary, and convert to kana to see if there’s a match with a command (in this case the “correct answer” command for WK). So the fact that you’re seeing kanji in the live-text is simply because that’s the way it comes down from Google – they don’t have any options to get voice recg. in kana! For WK it’s not ideal that Google outputs in this way… but you can imagine for most use cases people want Kanji with a STT.

Hope this clarifies things!

What I said in the second paragraph still applies, but this confirms the issue I mention in the beginning. The dictionary is missing some おんよみ entries, so I will expand it in an upcoming version – because kananized
苗字=名字 they’re homophones! Sorry! Will be fixed soon.


#69

Well, it works now, but I still don’t know why it wasn’t working before :woman_shrugging:
I didn’t change anything, went and did the mic test (showed working), so I turned LipSurf back on again and it worked!

There were a couple of troublesome items during the review, though:

  1. 旅館 meaning
    When I began to say “Japanese inn” LipSurf switched to Japanese mode immediately and wasn’t able to input the answer. I did check the synonyms and found that “ryokan” should be accepted, so I’ll try saying that next time. However, this seems like it would be a problem for any vocab meaning beginning with Japanese: Japanese food, Japanese style room, etc.
  2. 求人 meaning
    (made me LOL :laughing:) Saying “help wanted” opens the LipSurf help box.
  3. 念願 meaning
    There seems to be a problem with the apostrophe? Usually I omit it when typing, and the answer is accepted. Maybe I will try adding “hearts desire” without the apostrophe to WK as a user synonym.

#70

:joy: lol. Yeah, these are the same class of problem as going to r/you. The solution for this is a little more involved, but I will have it in 0.6 or 0.7. As a temporary workaround, you can disable the “help” command. Disabling the “Japanese” command might prevent you from saying “英語” and spelling out reviews, but I haven’t actually checked. If you want to try, just be aware of that :slight_smile:

Nice catch. Easy fix I’ll get it in the next version.


#71

Can’t manage to input 私営 (しえい) . I always get “ca”.
Same with 支援 (しえん), I get “cn”.

It usually gets my English (though I’m not a native speaker). It’s still 50/50 for Japanese. Short words are hard; it could also be my bad accent…


#72

I’ve added homophones for c<->し, a<->えい and n<->えん. Those will be on by default in the next version.


#73

v0.6 is released! Features and bugfixes are in the parent post. You can force an update sooner by going to chrome://extensions turning on developer mode then clicking “update”.

*Bug fixes that would cause LipSurf to suddenly stop working.
*Added homophones as per @blindcat97(g->じ) @Xtian, and @Helix (tested spelling “t-o-d-o-k-e-r-u” – it works) and other’s comments.
*Fixed apostrophe and hyphen issues as per @Saruko’s comments

Also many thanks to “Shadow” who emailed me videos demonstrating some issues (not sure of her handle here)


#74

Has anyone tried v0.6 yet? The only remaining issues that I’m working on fixing for the next version are:

  1. Conflicting commands (ie “r-u” going to reddit.com/r/you etc.)
  2. LipSurf staying on if you quit WK while in Japanese mode occasionally.

#75

Yes, it’s generally working well for me :grin:
Also, I’ve had a review with an apostrophe and it worked fine.


#76

I’m on Chrome OS 69, the extension doesn’t seem to initialize properly. After granting microphone permission it just spins forever.


#77

hmm that’s a weird one… Are you on 0.6? Did you try uninstalling from chrome://extensions and re-installing?


#78

Yes, 0.6; no, reinstalling didn’t help.
I opened up inspector and saw this, though:


#79

yeah ^^ finally I can combine reviews and knitting! thats awesome!

it has some trouble with my english, but as I am not a native speaker it’s probably a pronunciation issue on my end.
I did 20 reviews and it worked fine for me so far. The only problem I had was when the vocab meaning for 次 was asked. I tried spelling it out, but it showed me the correct letters at the top, but nothing was inserted into the textbox.


#80

Ah, yes, that makes sense :slight_smile: that will be fixed in an upcoming version. It’s the same issue others had above with commands taking priority over the wanikani command (since 次 is obviously itself a command)