LipSurf - WaniKani Voice Dictation. Review while you eat, do chores, etc


#181

True! Doing reviews will be free soon, (but not lessons). So I will update it once that is case.


#182

Okay, I’ll try it again at that point.


#183

First off, it’s a bit sucky that you didn’t make it clear that you need to pay to use the WK feature, I mean that’s why we’re on this site after all. Anyways, I bit the bullet and paid and so far it seems worth the money.

There are some annoying bugs though, for example I’ve just had 野球, I answered “baseball” and it somehow understood “google baseball” and replaced the WK tab with a Google search tab. This isn’t the first time this has happened.

Saying “to talk” opens Twitter every time, LipSurf even recognizes that I say “to talk” but it stills closes WK and replaces it with Twitter… Saying “to advance” does the same. I even deactivated “control browser-level actions” but that didn’t work either. (Edit: I’ve disabled Twitter and so on, that seems to work).

Then there’s the problem with the software nor entering what WK expects, for example I needed to say “第二章”, so I did and it correctly understood me (it showed “第二章”), but WK isn’t looking for kanji, it want’s the answer in kana, so I had to say “正しい” in order to move on. This has happened on several other words as well.

A similar problem occurred with the word “四十二階”, I said it out loud in English and the software understood “fourty second floor”, I also tried “floor fourty second” but the software showed “42nd floor” and “floor 42nd”, which aren’t accepted by WK.

I also noticed that something is restarting the WK tab from while doing reviews, this might be another speech command that the software is mistakenly activating while I’m saying something.

I hope these kinks can be worked out (or there’s a setting for it) because otherwise the software is great and I’d definitely upgrade for a full year.


#184

Thanks for your useful feedback!

It used to be free for WK (when I posted), I need to update the post to reflect it’s current state. I’m holding off until I get just just the WK lessons to be free (reviews will remain pro only).

All of the issues in this category (recognizing non-WK commands while in WK) will be eliminated with a feature I’m adding very soon (modes). It’s described a bit earlier in the thread.

This category of issue is the top-priority for the next release. It will be fixed in one of the small point releases (eg. 1.8.1).

Hmm numbers continue to present issues. What I’ll do is resurrect all my kanji/vocab and get them working one-by-one.

BTW, 1.8 is going to be released in the next few days. You will be able to add custom homophones/synonyms for troublesome words in the interim before the other fixes come out, at least. Here is a sneak peak of the features: https://www.youtube.com/watch?v=xkO0yji0IHY


#185

Which one is it?


#186

Awesome, thanks for the fast answer! :slight_smile:

I can’t believe that I easily did all 299 reviews that I had accumulated over the last few days in one go. I usually get seriously disinterested after 150+ reviews but today I actually had fun and wanted more, thanks to LipSurf. I believe I can even do the 7days/level challenge now, my only problem was getting too many reviews but it seems like this is a non-issue with this handy tool.

Also, are there any plans for BunPro and Memrise support in the future? Those are the two main Japanese learning websites I use next to WK.


#188

Darn! I always mix up those words somehow! Reviews will definitely remain pro only. Lessons might be free in a future version.

v1.8 is out the gates! I hope people like the custom homosyns adder (not talking about things you may have learned in Sunday school, but homophones and synonyms).

Also, there is a end-of-year sale until Jan. 8 for those who want to upgrade to one year.

Thanks for the kind words! I’m thinking about memrise for sure. Bunpro maybe, but I don’t think many people use that. If you want to show me how you envision using LipSurf with memrise maybe we can have a chat over Google Hangouts one day soon?


#189

Reviews are all I care about. :cry:

Unfortunately I can’t justify a monthly fee for this app since I’d only use it for WaniKani reviews.


#190

Sorry for the delay, I’ve been working on improving the backend recently. The next update will have most of the things you mentioned fixed, I’m expecting to be finished within a week :slight_smile:


#191

v1.8.1 has been released with some bug fixes:

  • Better microphone permission handling and troubleshooting in the tutorial and options.
  • Fixed issue with fonts on Windows and macOS.
  • More :ru: Russian translations and some fixes general language handling (including :jp: Japanese). Thank you @ulalasava!
  • Fixed issues on smaller resolutions (eg. help being cut off).
  • Fixed issue with custom shortcuts/homophones and synonyms metrics gathering.
  • Warning in the tutorial for Chromium users about incompatiblity. (Install Google Chrome instead).

#192

v1.9.0 has been released, this one is esp. important for WK users!

  • Fixed some issues with recognizing certain vocab/kanji with numbers in them.
  • Fixed issues with language switching for ja/en.
  • Added zoom in, zoom out and reset zoom commands

#193

Fixed in v1.9.1.

I also fixed all of the WaniKani numbers. At least I’m pretty sure I got them all, I went through and did them each manually to make sure they work.

Thanks for your comments @Liras a lot of recent improvements based on the feedback you gave :slight_smile:

v1.9.1 was just released a few minutes ago.


#194

Awesome, I’ll be sure to look out for anything noteworthy when I do my reviews later today.

Thank you for your hard work! :slight_smile:

Edit: This review session was definitely smoother than ever, thought the page reloaded twice at the end. Once was when I said ゆうどく and the second time was えいご. From what I can tell this only ever happens when I say the Japanese pronunciation of a word (or at least I don’t remember it ever happening with the meaning of a word).


#195

Hi,
Is the only way to test the extension in Wanikani to pay for a month?
I know you have many costs but 8$/mo seems a quite high price tag since I would be using this extension only in wanikani
(also quite sad that this works in chrome but not in chromium)


#196

Hmm, I put in one more fix that could have been causing that in the just released v1.9.2. Please let me know if you encounter it again, and if possible any more details about how it happens.

Yes, that’s the only way currently.

That should be directed at the Chromium devs., not me :stuck_out_tongue: It’s not likely to work on Chromium anytime soon as Chrome incorporates Chrome’s proprietary cutting edge speech recognition, and the open source speech recognition alternatives are still far behind (but up-and-coming!)


#197

I did 214 reviews today and it didn’t happen once. Looks promising. :blush:


#198

I just found a little bug with the vocab word 折り紙, if it asks for the English meaning it will always understand “Origami” but if it asks for the Japanese, then it will always understand “わにかに”. I’ve tried this close to ten times now and each time it understands “わにかに” and reloads the page.

I’ve even tried playing the voice clip WK gives you with the word and there it also understands “わにかに” instead of “おりがみ”, so it doesn’t seem to be a problem with my pronunciation.


#199

Nice find! I will make the WK answers take priority over homophones in the next version to fix that whole class of issues.

In the meantime you can disable the homophone in the options right now:
image

Thanks for letting me know!


#200

I’ve noticed some strange behavior in the last few days. If I say certain words then it will understand “top, up, した” even if I didn’t say anything like that. For example I say “to graduate” and lot of the time it understands “top” (marked in green, so it’s some kind of command). Also certain words that begin with “えい” like “映画館” are mostly understood as the command “英語” (same with “英語” itself), which causes the program to only accept English commands until I say “Japanese”.

I don’t remember these things being a problem before.


#201

Have you added any custom homophones? Can you check in your options under the “custom” plugin and let me know exactly what’s there?