Kitsun.io - [UPDATE] Subs2Kitsun Beta & Layout Sharing implemented! - Open Beta - Web-based SRS Learning Platform

Am I the only one that feels that the arrows should be reversed? So, to open the “Top Leeches”, the arrow should be pointing down and to close it, it should be pointing up (the opposite of what it is right now).

Yes, I got 飛行場 23 times wrong, got any problems with it? mad%20-%20Copy

miiii

3 Likes

I remember having this conversation with @Radish8 before :laughing:

I guess it depends on how you look at it. Does it indicate the current state, or the state that it will be after clicking the button? :stuck_out_tongue:

Yuuuup, so much this :joy:

Tbh, I feel like the latter is more intuitive? :thinking: That’s how Discourse works for example. Which one feels more natural to you?

1 Like

I missed one 25 times so I can’t talk about it.

2 Likes

This deck is using the official template… and this looks a little too chaotic D: (a card’s page)

Could you make like a setting for the deck where the user could choose light/dark mode? The default setting would follow the website’s theme (light vs dark). This way, we wouldn’t have to deal with so many layouts (and guess what: this would look less chaotic to people what have no idea of layouts/templates/etc iykwim :eyes: )

2 Likes

Well, I made those on purpose, otherwise I could have put it all into one general layout (per type) which would adapt based on your current theme. However, I figured people using light mode might still want to use dark cards and vice versa :stuck_out_tongue:

I do plan on hiding templates/layouts in general soon to simplify the card creation process.

2 Likes

Bug report: Pressing enter/return doesn’t work on Chrome - Mojave while doing lessons.

Strange. If I press “shift return” then it acts as “return”.

Hitting return while doing Lessons on Safari have been always normal so far.

Edit 1:

I just got いずれ again, and I got red. I’m not sure I understand what @jprspereira had said to me then :confused:

To make it green, here was what I did.

I added it as a synonym. And then, when いずれ comes again, I got green.

At least, I don’t need to hibernate this card. :woman_shrugging:

1 Like

I haven’t had others report the issue about enter not working in Chrome on a Mac :open_mouth: maybe someone else using a mac could confirm it?

The ‘enter’ code is pretty straightforward in that it listens to a certain keycode (the number for enter) so I don’t think the issue lies in the code there…

As for your edit:
This isnt an issue with kitsun I think, but rather an issue with the card itself (‘correct answer’ is empty). It is in the noragami deck right? If so we could ask @halfriver to accept the feedback that you sent inside Kitsun (iirc you previously did that?)

Thanks for reporting by the way!

2 Likes

I just tested it again on my chrome mac, “return” still didn’t work. This lesson. Not review. I haven’t had problems with pressing return on review session.

I got this next screenshot because I pressed “shift return”

Yeah. Let’s see if other mac users on chrome also have this problem :thinking:

Right. Yes. Ok.

Another problem: My iPhone couldn’t access kitsun. I tried accessing WaniKani, BunPro, or any other sites like Kitsun community, in Safari on iPhone 7 Plus worked fine. But not kitsun decks. I tried accessing kitsun on my android mobile, it also worked fine. Only on my iPhone. Just blank like this for a long time.

2 Likes

Hmm, I’m thinking the reason it’s not working for you is because it is a “flip” card (non-input), which has some different keybindings during lessons/quiz/reviews… In what part of the lessons isnt it working? the actual lessons or the quiz part?

You could also try to change the hotkeys for flip cards on the general settings page (accessed from the sidemenu).

!! That’s not good! It’s kinda hard to debug this problem but what I’d currently suggest is to clear the cache of the browser and try again. I’ll check with some other iphone users whether they experience the same problem.

Sorry for the inconvenience!

Edit: omg I just noticed I forgot to hit the reply button… Sorry about the wait!

1 Like

I have a deck ordered by index. However, if I go to each card, all seem to be displaying Index as “-1”:

Untitled

Is there something I’m not getting or?.. :thinking: All cards are being added from the Dictionary tool.

It’s the “Time to read takusan!” deck if you wanna check it out :rofl:

2 Likes

I’ve just tried it again on Chrome. Same. The actual lesson, not the quiz part. I haven’t tried learning lessons on Kitsun on Chrome until I answer the quiz part. I just closed Chrome because of this “shift return” problem and continued learning Lessons on Safari (unless if it’s Complete Genki Vocabs deck, I just use my mobile devices, because some audio don’t play on Safari)

Does it have anything to do with any Chrome Extensions I have?

I tried clearing Safari cache on my iPhone for the first time using this google search result

And it worked! Thanks! Now I can use Kitsun either on my Android phone or my iPhone :heart:

No worries. I still love Kitsun so far.


Another feature request (I hope this hasn’t been asked).

Can we have this submit button inactive after we click “Generate Card!” so that we know that the previous clicked one is already being processed? And can we have duplicate detection feature when adding/generating a card from dictionaries? Like when I add a duplicate card on anki, the field will go red. Maybe on Kitsun, warning message should be good? Only to let user know that this exact card exists on the chosen deck.

Another solution could be: Auto detection duplicate cards from Cards Listing on a Deck. Like displaying a certain icon? Or a menu on top to offer “Detect duplicate cards” although the card isn’t exactly duplicated, let’s say card A has a tag “leech” and card B doesn’t have any tags, but they both contain same values/fields. So it only detects same cards on the same decks, not on different decks (from Listing cards/My Cards menu).

3 Likes

Index must be specified per card during creation, normally speaking. The (default) dictionary card generation process doesn’t have an option to specify the index (to keep it as simple as possible).

That said, why would you want to use Index-based ordering on that deck if chronological would make sense as well? I take it you are adding cards while reading? (with the app I mentioned? :smiley:)

Chronological should suffice in that situation I think?


@Oshin Hmm, that does sound like a bug then… I don’t think your extensions have anything to do with it unless you have userscripts for Kitsun installed. I’ll try to check it out tomorrow!

It’s still weird that this happened in the first place, but I’m glad it’s solved ^^

:heart_eyes:

Good call, will do!

This one is a bit harder, and is in line with some other problems that have the same cause:

Templates are created by users, meaning they can contain any number of fields and any kind of fields. This also means that for template A, the “vocabulary” field might be field 1, while for template B the “vocabulary” field might be field 3. Next to that the actual names of the fields can be different.

Because of this, Kitsun doesn’t really know where to search for duplicates. the value “door” might be used in a large number of cards, and it wouldn’t know which one is the duplicate…

This problem is something I’ve been brainstorming with multiple people about but so far I have no good solution for this yet.

3 Likes

I don’t want to, I was just curious xD The deck is set to Index’s order by default, so adding words and all having -1 index looked weird to me. I reported just in case that wasn’t something to be expected :man_shrugging:

Yes, and not with the stuff you recommended me XD I’m going old-school way (aka I’m too lazy to get your way to work, but I’m willing to spend more time using a more inefficient process) :eyes:

2 Likes

Its literally just downloading the app and setting 1 URL though :stuck_out_tongue:

1 Like

<.<

Btw, what feature does this activate? The “custom flashcard” or the “generate flashcard”? I use the former because I want it to use 3 layouts (EN => JP) included :thinking:

2 Likes

It brings you to the dictionary page where it automatically searched jisho for the word that you want to look up. From there you can create the instant flashcard or your custom flashcard

1 Like

Ohhh right right! It just does kitsun.in/dictionary/wordhere.

忘れた xD

2 Likes

@elynchbell and other mobile users, I believe I’ve found a way to fix it. I hope to implement it with the next update (this Sunday probably). :smiley:

Edit:

Considering I’m talking about mobile anyways:

I’m in the process of creating prototype native apps for iOS and Android.

And I wish to tackle Offline functionality while at it. Needless to say this is a pretty huge project and will take quite some time, but I want to release a prototype as soon as possible :slight_smile:

No promises, as I’m not fully familiar with all the limitations of the techniques I’m using for them, but it does look quite good so far.

7 Likes

So, I was just creating a card from the Dictionary - Custom flashcard and on the last step “Generate card!”, the page was somehow laggy, so I clicked twice. Guess what, it created 2 cards of the same thing :rofl: Can this be fixed?

2 Likes