Kitsun.io - Self Study now implemented! - Open Beta - Web-based SRS Learning Platform


#1833

answer. for example a,b = wrong but a/b = right.

Only one answer with commas passed


#1834

So your answer should be either a or b, or do you mean its gotta be “a,b”? If its the latter then it’s the splitter interfering

I’m asking because I recently changed the answer validation process


#1835

It is either a or b. I was just entering a,b which was wrong. It’s a two answer question. I need both answer for the question to be correct hence why I changed it to a/b.

There is no bug i’m just starting to understand how I was using only 1% of the entire application :stuck_out_tongue_winking_eye:


#1836

Ahhh I see, that’s good haha ^^


#1837

I should prob start looking more carefully a tthe updates ha ha.


#1838

Using the 10k Deck- today the audio icon disappeared. If I click the blank box, it works, but the play icon was gone (it is blank in all places it should be in the deck) and I got confused.


#1839

In your screenshot it seems like it’s missing all icons. Which means that the font responsible isnt being downloaded. Could you try a full refresh (ctrl+shift+r) and let me know if its back?

I just checked and the link where it is downloading the font from is still working correctly. It might be that your browser cache got corrupted, or the link is blocked, preventing a download of the font.


#1840

Tried a full refresh, closed browser tried again (I’m using Crome 71.0.3578.98 (Official Build) (64-bit)) . Didn’t fix it. ITs working fine in my edge browser so I don’t think its a network thing. I was using it yesterday just fine.

I’ll restart my computer, maybe that will do it. Thanks for troubleshooting.

BTW, the 10k deck the layout really really shines. I am super impressed by it.


#1841

Hmm, perhaps you have a adblocker which accidentally blocks the font?

You could try to clear the browser cache for Kitsun to see if that helps.

I don’t know how technical you are, but you could also take a look at the network tab in the console (F12) and check if line-awesome is loading in alright (filter by css). You might have to refresh the page to get it to appear though.

Let me know how it goes and if you need more help! I’d like to solve this with you :slight_smile:


#1842

I think that now they don’t show up at all :rofl:

One thing is for certain: when a card with sibling filtering on is marked as wrong, it should show the rank down notification, but it isn’t.

I also didn’t get any rank up notification on 34 correct reviews (with sibling filtering on), so I guess it’s not ranking up either.


#1843

They only show up when you actually rank up cards, aka done all the layouts. Perhaps the ones you did still have a delay for the next layout?


#1844

40+ cards and none went up? xD Hard to believe.

My point is that no matter if there’s another side of the card missing, if a card gets a wrong answer, it goes down on the SRS system. So the notification should still show at all times for wrong answers, which it didn’t.


#1845

If it’s all from the same batch at the same stage (so e.g. layout 1 of 2) then it could be possible.

A card only goes down on SRS after you answer all siblings (of which 1 or more were wrong) as well.


#1846

I just did a few reviews without filtering siblings and the notification comes up, but I was also doing a few hundred reviews for 4.5k and 10k (with filtering) and had the impression that something is wrong.


#1847

Hmm, I’ll go check it right now.

Edit: Found the problem. Fixed it for the next update :slight_smile:


#1848

No update today, hard at work on a new feature!

Making great progress on a general export and export -> reimport into existing cards feature (to allow for mass editing cards in google sheets/excel or some other programs). Can probably finish it this weekend :slight_smile:


#1849

Omg I’m laughing so much right now :man_facepalming::joy:

Sooo! One question: Do the tags on the excel file need to be together? For example, do I have to write “Chapter3” instead of “Chapter 3”?

Because what I did on the excel file was: “Chapter 2, Page 61”

And this was what got imported:

iui

Should I have done “Chapter2, Page61” instead? And if so, wouldn’t it be better to allow spaces in tags? :thinking: So a tag being “Chapter 2” instead of “Chapter2”?

I have another problem but I’ll let you know about it tomorrow :joy: now I’m dying lol.


EDIT:

Ok, the other problem is that I’m losing data going from an excel file to csv :thinking:

CSV file:

Am I saving it the wrong way? :man_shrugging: im so dumb omg


#1850

I think it was a cache issue- when I booted my laptop today and used kitsun everything was fine.


#1851

The tags should be split on “,” having spaces in there shouldn’t matter afaik… Might be a bug in the import that has gone unnoticed so far.

I don’t know exactly how you save the file from excel :stuck_out_tongue: I think theres an export option or you could just copy paste it into a txt file (iirc).


#1852

Ah great! That’s good to hear ^^