Is anyone else recently getting HTTP 402 errors using AlliCrab?

I’ve been using ALlicrab in my iPhone 6s for about 2 years, and now am getting connection errors all the time. HTTP 429, which is a client error, to be specific.

Usually after I refresh about 10 times it temporarily resolves itself. But I never got the error at all until about 3-4 days ago.

Is anyone else experiencing this?

All I know is the beta works fine. Maybe you should try to get that version.

Hmmm…what version number is that? I am using AlliCrab version 2.3 build 67.

I’ve been getting a ton of connection errors the last day or so. My error message says 429, but it’s still a client error. I’m on iPhone 5c. I think I have the same app version as you.

It fixes itself and can sync the review numbers etc for a little if I log out of WK and log back in, but it doesn’t stay fixed.

Yeah, I’ve been having problems too. I mostly do my reviews on Tsurukame and use Allicrab for browsing the forums, but I notice it frequently doesn’t have information about my level, reviews, or lessons correct when I open it. And I’m assuming I’m getting the same error message.

I’m using version 3.0 build 75.


EDIT:
@viet @oldbonsai Is it possible something is wrong with the v1 API? Another user and I got rate limit errors for Real Numbers and @windupbird is seeing the same error for the released version of Allicrab which also uses the v1 API.

I’ve been getting problems with the Android app as well. It takes a few tries to get the correct number of reviews available (internet connection is fine).

2 Likes

They should show this for the error message:

4 Likes

We are taking a look into this.

5 Likes

I think I’ve pinpointed the issue. It’s going through code review now. Sorry about the inconvenience.

5 Likes

So does mine, I misspoke in the opening post. I’ve went back and edited it. :slight_smile:

Ok I deployed a fix. It’ll be a few minutes for the rolling restart to occur. The throttling should be less aggressive on the v1 endpoints now.

3 Likes

It seems to have resolve the issue. Thanks.