Introducing KameSame - a new reverse-Wanikani web app!


#347

I might have found an (unrelated) bug this time. The word: 心願 in the synonyms shows as: Heart''S Desire.


#348

Sorry for the delay, but this is fixed now for me! Thanks and keep up the good work!


#349

Hi! I just started this–what a fantastic idea; I realized I had the same issue going from English to Japanese and this is exactly what I need.

I’m not sure if this is the right place to leave this kind of feedback, but for “tree” (木), although I my answer was correct, it said the pronunciation is もく, which is the onyomi; since the kanji is by itself, should it not be the kunyomi き instead?

Thanks again for a great product.

Edit: ah perhaps this is because it was a kanji reading as opposed to a vocab reading, and all kanji readings go with the onyomi–is that correct?


#350

What was the background colour of that tree kanji? Was it red? Or was it purple? If it was red, it meant it referred to kanji, same like on WaniKani (Summary: RED -> KANJI). If it was purple, it meant it referred to vocab, same like on WaniKani (Summary: PURPLE -> VOCAB).

Summary:
RED -> MOKU
PURPLE -> KI

Not always like that. But mostly yes as far as I know.


#351

i think this is a bug, no?


#352

Perhaps not. We talked about this stuff some posts back. There are characters in the unicode set that look alike but aren’t the same. How did you input that?


#353

I’m pretty confident I typed おう, followed by one press of the down arrow + return to select the kanji, but perhaps I hit some extra key somewhere and messed something up.


#354

If you wouldn’t mind, if you’re able to replicate this, copy-paste the characters themselves from the app into this thread so that we can check the UTF codepoints and debug it


#355

Indeed. We go by whatever readings WaniKani uses. However, remember KameSame is trying to get you to input the kanji itself wherever possible, which obviates this as an issue (getting just the reading of a vocab word is only considered half-right, and entering the reading for a kanji card does not count as correct).


#356

hasn’t happened again, but i’ll do that if it does.


#357

Hi! What does the WaniKani rank option do?


#358

It will only pull in lessons at or above that level in WaniKani (i.e. if you select Enlightened, you won’t get lessons for items that are Apprentice/Guru/Master ranked in WaniKani)


#359

@searls I wonder if I could remove some/all kanji on KameSame? I’ve been adding vocabularies only for these past few weeks.


#360

Yes, if you search for the kanji you want to remove you can click “Reset this kanji”


#361

perfect. thanks!


#362

Major Update #4: Account management & password reset

Since I wrote KameSame primarily for my own use, I didn’t bother with a bunch of typical things you might expect, like:

  • Field validation that name isn’t blank, email is unique, or that WaniKani API is valid
  • Ability to change name, email, or password
  • Ability to update WaniKani API key (if you regenerate it)
  • A password reset feature

Well, KameSame has all of that now. It was every bit as annoying and laborious as I expected. Check out the new goodies in the account page:


#363

What I typed: 大きい
What it expected: 大きい

The above are copied and pasted. FWIW:

image

I’ve left the tab open in case you want me to use the console to execute some JS to test anything.

Edit: also just happened for kanji for woman: 女 (\u5973 for both; tab also still open)

Second edit: also just happened for kanji for power (カ), although this time it looks like I did screw something up (which probably rules out this specific issue for the other two cases):

image


#364

Okay, I tried it and it worked, but only for a certain kanji. I wonder if I can delete (reset) all kanji on KS? Because I once deleted kanji one by one, until that beachball appeared again on my Safari. I couldn’t screen capture the beachball, I had to force quit my Safari. I think I’ll just want to test vocabularies on KS. I don’t want to type and press space over and over to find the correct kanji writing for a kanji.


Why does WaniKani only focus on Japenese -> English and not the other way around?
#365

I don’t have a feature to support that right now, sorry. If you’re having trouble with Safari, I’d encourage you to try with another browser for this.


#366

Thanks for this @ilyakamens, but for the life of me I cannot reproduce it, locally or in production. What device are you using?