Installing Wanikani Open Framework

Ah, that makes sense. My first thought was that it’s Opera messing around with script execution order, glad to see I was wrong.

ah, thanks! i just had a look and my open framework was like #6 so i fixed it now

just fyi: firefox user with a broken indexedDB here. got it to work after a reinstalling firefox and restoring only essential things (bookmarks, extensions) from my profile-backup. although it kinda seems as though the error occured somehow with installing WK open framework (?), because after that out of nowhere another extension (RSS feed reader “brief”) also stopped working entirely :sweat_smile:

but now everything’s fine and wanikani with a fuckton of userscripts is a real blessing :slight_smile:

1 Like

I just installed the script, but it doesn’t seem to work. :frowning_face:
I had once installed it before, and it worked just fine, then I deleted it and this is the second time I’ve installed it, could that be the problem?

imagen
imagen

EDIT: Never mind, apparently the Reorder script doesn’t work like that. :grin:

Hi! I’m trying to install the Open Framework into my internet browser (Chrome) but it seems that my computer/software (Dell laptop/Windows 7 - rip, it’s my work computer) won’t allow content/code from Greasy Fork to be installed. Is there anything I can do to work around this or some other code I can use that will allow me to install userscripts? Thank you!

Nevermind! Just realized I needed to add the TaperMonkey extension first - it’s all working fine now! Hehe ^^

1 Like

Thank you! ^^

I’ve been using Open Framework for a long time, but recently I started noticing that every time I use it Wanikani doesn’t show the SRS level during reviews :sob:
I’m using Chrome Version 68.0.3440.106 (Official Build) (64-bit)


I’d really appreciate your help :grin:

In your screen-capture, you have the framework disabled.

I disabled it because I want to see the SRS level during reviews, but I still want to use the userscripts that only work with the framework.

Ahh… so SRS Level isn’t a framework script, and you’re saying it works with the framework DISabled, but not when it’s ENabled?

When I ENable the framework Wanikani won’t say Apprentice, Guru, etc. (during reviews)

@rfindley Interestingly, someone else was complaining about my Show Specific SRS Level in Reviews script not working in Chrome, but I couldn’t reproduce the issue. And I’m able to run it with Open Framework running just fine…

1 Like

Okay, I see.

First, confirm that your settings page hasn’t changed for some reason:
https://www.wanikani.com/settings/app

Also, keep in mind that the SRS Level indicators only show up after you’ve completed both the reading and meaning.

Beyond that, the framework doesn’t actually do anything on the Reviews screen unless another script asks it to. So, maybe one of the other scripts is interfering. Double-Check, for example, actually controls the SRS Level indicators.

But I just checked both the Framework and Double-Check (and Reorder Ultimate 2), and I’m not seeing any problems. I’m on Windows 10 + Chrome Version 68.0.3440.106 (Official Build) (64-bit).

[edit: While checking my Chrome version, I noticed Chrome just started downloading a new version. I’m in the middle of some stuff, so I can’t restart my browser to see what the new version is. But maybe try the new version to see if that changes anything?]

[edit2: Actually, all of my tabs were okay to be reloaded, so I just upgraded to Chrome Version 69.0.3497.92 (Official Build) (64-bit) ]

1 Like

Actually, I wanted to complain there’s no “Apprentice”, “Guru”, etc during reviews too but not because of the WK Open Framework, but because WK Double Check, I disabled WK Double Check, then I installed WK Override (because I don’t want to wait for WK Double Check being fixed, see my post on WK Double Check thread), combined with Specific SRS and WK Lightning Mode, the “Apprentice n”, “Guru n”, etc during reviews work again.

I got my Chrome updated too, maybe double check… I’ve been enabling and disabling both scripts at the same time until now… :flushed: I’ll try that and come back.

So it is double check… :sweat_smile:

I find this so interesting, because I also use Double Check. Maybe it’s an ordering issue?

Can you paste your Double-Check settings? I’m still not able to reproduce the problem.

Edit: Double Check isn’t showing the SRS Level when Lightning Mode is enabled. I don’t remember if that’s how it usually works. I may need to add a setting for that.

2 Likes

That would be a difference potentially because I don’t use lightning mode.