Installing Wanikani Open Framework

Maybe clearing the cache did not correctly delete the IndexedDB on mobile? I did a quick internet search and there seem to have been problems with that in the past.
Just to make sure that the IndexedDB is really cleared, you could use a userscript that I’ve just made (it only contains one line: indexedDB.deleteDatabase("wkof.file_cache");). Just be aware that this also resets all settings for wkof userscripts.

  1. disable all Open Framework dependent WK userscripts in Tampermonkey.
  2. install IndexedDbClearer
  3. go to - upon loading the page the indexedDB should be deleted
  4. delete the IndexedDbClearer userscript in Tampermonkey
  5. re-enable all other userscripts in Tampermonkey
  6. complain that it didn’t help at all (if applicable) :stuck_out_tongue:

Oh my good lord thank you so much!!! It worked!


Thanks again for the IndexedDb script, but it seems there is deeper underlying issue. :sweat_smile:

Once I use your script, everything works once, but I unfortunately need to reuse the script again if I want to refresh the page or use scripts on another page.

After having used your script, disabled it, and refreshed with the other scripts once, I usually still get the WKOF loading screen (!). Then between 0-2 bars load instantly without intermediate steps (intermediate steps occur for me when it works) , and the WKOF closes without finishing loading everything. I usually see the top bar of the Ultimate Time line script with the settings and the slider, but that’s about it. (I can confirm it is not minimized or anything, it’s just not loaded.

At least it works, but could there be a clear reason why my IndexedDb corrupts (?) every time I use it?

I’m sorry to hear that. Have you already tried it with only one script enabled (for example only the ultimate timeline (and of course WKOF))? I’m afraid that I won’t be able to help with the problem - I don’t even have a smartphone, so I cannot try to reproduce this.

1 Like

No problem, thanks for helping me.

I opened each separately, and found that Ultimate Timeline and Dashboard SRS and Leech Breakdown seem to break everything. I looked at what they loaded, and the breakdown script loaded the same attributes from WKOF as the scripts without the issue (Assignments, subjects, review stats), while Ultimate Timeline seemed to load the same, apart from Review Statistics. So I don’t think that has something to do with this.

I kind of found a temporary solution though! I have put your script as the first script to run in Tampermonkey. This means that my IndexedDB gets wiped every single time, but at least my scripts work consistently now. I’ll just change my default settings in the scripts themselves.

Thanks again for your help!

1 Like

Hi, just wondering: Is it possible to use WKOF in the current dashboard preview? Somehow adding an “@include” didn’t seem to fix this, but it would be neat to be able to get our scripts updated before the new dashboard goes live. Many thanks for your hard work :slight_smile:

1 Like

I’ll look into it to see what might be preventing it from working. It’s possible that some URL checks in the Menu and Settings modules are preventing those modules from running properly. But as far as I know (without digging deeper yet), the core should be able to load okay.

1 Like

I’ve posted an update to WKOF and Ultimate Timeline to support

Hopefully, the new use of regular expressions in the @include doesn’t break the scripts in any non-TamperMonkey script managers. I think it’s standard, :crossed_fingers:.


Hi there everyone!

I am really new to all of this, so I apologize in advance if I am making some kind of obvious mistake.
I just installed the Open Framework and couple other scripts, however it doesn’t seem to be working for me. Whenever I open up the dashboard, none of the scripts work, and a couple errors pop up. I tried the IndexedDBClearer that was posted earlier in the thread(since that’s what I thought might be the issue), but whenever I open the Open Framework again afterwards it still doesn’t change anything. I have attached screenshots of both the error messages and my userscript list:

I am currently on the latest version of Firefox. Please let me know if there is a way to fix the issue. Thank you for any help!

Did you try just clearing cache?

Yes, I cleared my cache multiple times before attempting the IndexedDBClearer, but it didn’t work : (

I don’t think there is any other identified solution

That sucks : (
Thank you for helping me anyway!

Are you using a private window?


Ah, yup. I was, and now it works fine. Thank you so much!!


You got it; happy learning!

1 Like

Is anyone else having a problem with the lesson reordering script now that the new dashboard is in? I’m using, and while the ultimate timeline still works beautifully, the lessons can’t be re-ordered. But, if I open a new tab, go to, and go to lessons, I can re-order lessons to my heart’s content.

Any ideas? Thanks!

Reorder has most likely just not yet been updated for the new version

Thanks! Until they take away “regular” wanikani, I can just go over there for lessons and preview for reviews :slight_smile:

Just to add a post here for anyone else stumbling into the thread with a similar issue (since it took me longer than I’d like to say): I was trying to get WKOF+dependent scripts to work on FF+Tampermonkey, but followed the suggestions in this thread (including the indexedDBcache script) and was getting nowhere. The firefox console pointed to CORS errors, which could be caused by adblock pro + umatrix, which I have, but both of them were disabled for wanikani. After poking around a while I disabled all my firefox addons in the actual about:addons window, and things started to work, at which point I enabled everything again (to bring it back to its original state) and suddenly everything worked. I’m guessing there was some site data that wasn’t completely cleared until they were yanked from the browser, or something.

So if you’re having WKOF issues and any privacy addons, try disabling them at the browser level, loading Wanikani+WKOF again, and then re-enabling that if it works, even if they’re already set to not run on wanikani.

1 Like